Board index FlightGear Support Multiplayer

Can't get connected to Flightgear multiplayer servers  Topic is solved

Trouble getting online, setting up a server?
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- copy&paste your commandline.

Please, also see Requesting Technical Help.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Can't get connected to Flightgear multiplayer servers

Postby travlemon » Thu Nov 17, 2011 10:30 pm


I am still a bit new to Flightgear, and still learning. I am having some problems getting connected to any of the multiplayer servers. I have tried multiple servers, but have been frequently trying mpserver05, as it seems more populated at the moment. Here are the steps I'm using, as referenced from the Multiplayer Guide (

I open up FGRun and select my aircraft and airport as normal. Then, on the config page, I check the box to enable AI Models also check the Multiplayer box. In the hostname field, I fill out and use port 5000 in the In and Out fields. Then, I simply run the game as I normally would.

I chose the San Francisco airport because it seems to be the most populated, and it would help me identify whether I'm connected and seeing other pilots or not. When I get into the game, I see no other aircraft, though the MP Map shows there are planes at the airport I'm at. Also, if I choose Multiplayer>Pilots, it says there are 0 pilots, and I also don't see my call sign showing up on the MP Map.

I think I've pretty much verified that I'm not getting connected, but can somebody help me try to identify what I'm doing wrong? I also tried addressing the host name as, with no luck. Additionally, for good practice, I forwarded port 5000 to the IP address of the machine I'm trying to make the connection from.

My specs are:
OS: Kubuntu 11.10 32-bit Linux operating system
Graphics: Nvidia 9600M GT
Memory: 4GB
Flightgear version 2.4.0

Any help is much appreciated! Thanks in advance!

EDIT: I got a chance to try some more things. Disabling my router's firewall had no effect. Also, I noticed that in the menu Multiplayer>Multiplayer Settings, it reports that I am connected to the server. As mentioned above, I am on what appears to be an empty "server" though I tried connecting to several that MP Map shows people flying around in.
Posts: 12
Joined: Tue Nov 15, 2011 9:46 pm

Re: Can't get connected to Flightgear multiplayer servers  

Postby travlemon » Fri Nov 18, 2011 2:34 am

I have found a solution here on the forums, after a bit of research. For anyone who may need it, here's a link to the thread where I found the fix:
Posts: 12
Joined: Tue Nov 15, 2011 9:46 pm

Re: Can't get connected to Flightgear multiplayer servers

Postby Pablun » Sat Aug 04, 2012 10:24 pm


It was obvious, but i have had so many problems to get coneccted with mi fg 2.4.0 in win7, that i dont check this setup at my linux ubuntu becouse i thougth it was imposible for me to connect. Now fg multiplay works, and better than in win7.
Posts: 7
Joined: Wed Dec 07, 2011 12:45 am

Return to Multiplayer

Who is online

Users browsing this forum: No registered users and 2 guests