Board index FlightGear Support Multiplayer

MP does not reconnect to network after temporary drop

Trouble getting online, setting up a server?
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- copy&paste your commandline.

Please, also see Requesting Technical Help.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

MP does not reconnect to network after temporary drop

Postby Kabuki » Mon Oct 31, 2011 6:59 pm

This is a problem for me as I fly on unreliable network connections most of the time. I'll be flying, watching myself on the mpmap, and then I'll have a temporary loss of connectivity to the internet. I use public WiFi connections, so there's nothing I can do about it. Usually these drops of service are a minute or less, but once I'm reconnected, I am no longer on the mpmap. I won't be able to see myself again until I restart (not 'reset') flightgear.

There's an entry on the debug menu for 'reload network' but it doesn't fix it. I'd think that's what it's supposed to do.

Is there anything I can do about this? A while ago, I tried to fly from Tokyo to Nagoya, and lost the network about halfway, and well... my navigation skills did not save the day.

I am dead.
This is a family-friendly saloon. No talk stink.
Kabuki
 
Posts: 587
Joined: Fri Oct 23, 2009 11:21 pm
Location: Usually on the ground, always in the sky, except when underwater.
Callsign: Kabuki
Version: 3.0.0
OS: Windows 7

Re: MP does not reconnect to network after temporary drop

Postby kuifje09 » Wed Nov 02, 2011 9:14 pm

Strange, I just tested it with my ubuntu linux, several times. Unplugged the network wiat some time and replug.
I see myself flying on the live-map. Even Skype jumps to live again.

Maybe because of windows ? maby because of wifi ? But not just the temporarely network disconnect.
Does your IP-adres change after the outage? That could for shure be a problem.
kuifje09
 
Posts: 579
Joined: Tue May 17, 2011 8:51 pm

Re: MP does not reconnect to network after temporary drop

Postby Kabuki » Fri Nov 04, 2011 1:28 am

I'm not at all surprised that it's different with Linux.

The WiFi place that I usually use is very unreliable at times, and at other times, it's ok. The IP number doesn't change.

It's not a consistent problem, either. Sometimes, I'll have the pilot list on screen, and see it suddenly go empty, and
then repopulate itself after a while. That wasn't working the other day. I should have been paying more attention to
the console window, I guess.

The net's running really, really slow tonight, so maybe I'll see it again.
This is a family-friendly saloon. No talk stink.
Kabuki
 
Posts: 587
Joined: Fri Oct 23, 2009 11:21 pm
Location: Usually on the ground, always in the sky, except when underwater.
Callsign: Kabuki
Version: 3.0.0
OS: Windows 7

Re: MP does not reconnect to network after temporary drop

Postby kuifje09 » Fri Nov 04, 2011 8:17 pm

Okay, I get it, but you name 2 problems now. My network is not being interupted at all under normal circumstances, but the pilot list also sometimes "toggles", same as the live-map. Al planes are gone and in a while they come back.
That may be a question of timing I think, but if you realy lose the connection you are probably lost.
Are you shure you don't get a new address sometimes. Thats a bigger problem.
Unfortunately, I have no experience in working over WIFI.
kuifje09
 
Posts: 579
Joined: Tue May 17, 2011 8:51 pm

Re: MP does not reconnect to network after temporary drop

Postby someguy » Sat Nov 05, 2011 3:24 am

The mp system barely works under the best of circumstances, and seemed especially flaky today. Loss and reappearance of all pilots is common, and the box next to my name in the list frequently unchecks itself, but in mid-session today mpmap started showing everyone but me, and all other pilots vanished from my sim. A shift-escape reset did not help, either.

It's only a shiny toy, after all...no point in getting too exercised. If you ask, they'll give your money back. :) I just accept and enjoy fg for what it is. When it stops working, I do something else for awhile.
User avatar
someguy
 
Posts: 1653
Joined: Tue Nov 25, 2008 5:54 am
Location: USA
Version: 2016.2.1
OS: Mac OS X 10.11

Re: MP does not reconnect to network after temporary drop

Postby Kabuki » Mon Nov 07, 2011 6:09 pm

The timing of my post was somewhat ironic. As I mentioned, the connection had been flaky. The next day, they got a new ISP, and things have been working 100% better since then.

So I don't know if the issue(s) is(are) worth pursuing. The pilot list issue is a fairly minor annoyance. The "not reconnecting" issue is serious, IMHO, but I might not
see it again. I'm pretty sure the IP stayed the same after reconnection, but even if does change, it seems to me that it shouldn't be fatal. The mpserver gets each
client's IP every time... no?

I don't know... I can't reproduce the error, so...
This is a family-friendly saloon. No talk stink.
Kabuki
 
Posts: 587
Joined: Fri Oct 23, 2009 11:21 pm
Location: Usually on the ground, always in the sky, except when underwater.
Callsign: Kabuki
Version: 3.0.0
OS: Windows 7

Re: MP does not reconnect to network after temporary drop

Postby kuifje09 » Mon Nov 07, 2011 9:32 pm

Have a nice flight.
kuifje09
 
Posts: 579
Joined: Tue May 17, 2011 8:51 pm


Return to Multiplayer

Who is online

Users browsing this forum: No registered users and 2 guests