Board index FlightGear Support Flying

C172P rudder acting strange

Controlling your aircraft, using the autopilot etc.

C172P rudder acting strange

Postby mkoch » Tue Oct 02, 2018 1:42 pm

Hi, I've just updated FlightGear on Debian to the latest available version. I have Thrustmaster pedals, and the Hotas Warhog Joystick and Throttle. The problem is that when I start the c172p model, the rudder is all the way to the left and it moves only between the far left and middle position. I checked the joystick settings: the only axis from the 3 controls assigned to rudder is the correct axis of the pedals, and it goes correctly from -1 to 1. What's more, the virtual pedals inside the cockpit move correctly too, they reflect the position of the Thrustmaster Pedals. As to my best knowledge Cessna 172 doesn't have a rudder trim, so currently I have no clue what can cause this strange behaviour. I tested with some other aircrafts, like the Citation or the Tu154, those were working fine. Any suggestions? Thanks in advance!
mkoch
 
Posts: 1
Joined: Tue Oct 02, 2018 1:30 pm

Re: C172P rudder acting strange

Postby sim » Fri Oct 05, 2018 6:18 pm

Long shot try removing/disabling the xml files in the joysticks default folder?
Also see if rudder pedals work any better with your joystick un-plugged?
Since other plane's rudders work ok maybe C172 files are corrupted? :|
User avatar
sim
 
Posts: 1387
Joined: Tue Jun 30, 2009 2:13 pm
Location: Shropshire England
Callsign: Fly4Fun
Version: 0.9.10 up
OS: 64 Win 10 HD6450

Re: C172P rudder acting strange

Postby dany93 » Fri Oct 05, 2018 10:28 pm

I checked the joystick settings: the only axis from the 3 controls assigned to rudder is the correct axis of the pedals, and it goes correctly from -1 to 1.

Something that I'm not sure to understand well: since you have rudder pedals, your JS (Hotas) axes for the rudder should be cancelled (every lines for this rudder control should be commented out or deleted). Is it the case?

As many aircraft, the C172 has a rudder trim correction, but it is a pre-set, adjustable only on the ground. The FG Cessna 172 does have such a rudder pre-trim (0.02, which is weak), but I don't think it is the issue.

Isn't your autopilot activated?

In the simulator, with the c172p, check the trim values (controls/flight/aileron-trim and rudder-trim). They should be at 0.022 and 0.02 respectively at start. You can set them at 0 for testing, no matter.
dany93
 
Posts: 726
Joined: Mon Sep 07, 2009 3:43 pm
Location: France (Paris region)
Version: 2018.3.0
OS: Linux Mint 18 (64 b)


Return to Flying

Who is online

Users browsing this forum: No registered users and 3 guests