Board index FlightGear Support Flying

[2017.4.0] Unable to start FG or launcher

Controlling your aircraft, using the autopilot etc.

[2017.4.0] Unable to start FG or launcher

Postby dg-505 » Thu Nov 30, 2017 6:40 pm

Hi all,

when I type fgfs or fgfs --launcher in the console FG doesn't start, instead it returns the following error:

Code: Select all
fgfs: symbol lookup error: fgfs: undefined symbol: _ZN6SGPathaSERKS_

I use the latest PPA from saiarcot895's flightgear-daily PPA on launchpad on Ubuntu 16.04.

Recently there was an update for this PPA for the simgear package while the flightgear package failed to build.
After I did a sudo apt-get upgrade, I got this error when trying to start FG.
Maybe this has something to do with the error?

Anyone any idea? ;)

Thanks
Jonathan
It's not just a hobby. I'ts a passion: FLYING !!

DHC-6 Twin Otter development
User avatar
dg-505
 
Posts: 614
Joined: Mon Jun 02, 2014 2:36 pm
Location: Hessen, Germany
Version: next
OS: Ubuntu 16.04

Re: [2017.4.0] Unable to start FG or launcher

Postby wkitty42 » Thu Nov 30, 2017 8:32 pm

have you pinged saiarcot via PM in these forums? he is generally pretty responsive... not sure he'll see your post in this sub-forum area, though... not sure where it would be better off placed but i'm sure a moderator or admin will move it if needed ;)
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4539
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: [2017.4.0] Unable to start FG or launcher

Postby saiarcot895 » Fri Dec 01, 2017 5:18 pm

Let me check and see if the issue is still happening. Most likely, flightgear needs a rebuild to with the latest simgear.
Saikrishna Arcot

My FlightGear PPAs: FlightGear Stable, FlightGear Development (Edge)
saiarcot895
 
Posts: 293
Joined: Sat Feb 02, 2013 4:26 pm
Callsign: flyhigh
Version: 2018.3.0
OS: Ubuntu 18.04

Re: [2017.4.0] Unable to start FG or launcher

Postby dg-505 » Fri Dec 01, 2017 5:38 pm

Great, thanks you ;)
It's not just a hobby. I'ts a passion: FLYING !!

DHC-6 Twin Otter development
User avatar
dg-505
 
Posts: 614
Joined: Mon Jun 02, 2014 2:36 pm
Location: Hessen, Germany
Version: next
OS: Ubuntu 16.04

Re: [2017.4.0] Unable to start FG or launcher

Postby rustemy » Sun Dec 03, 2017 7:05 am

I've just downloaded the latest nightly build from "LP-PPA-saiarcot895-flightgear-edge" in the hope that it addressed the above error. I can confirm that the error is still there as I also receive the error message:
fgfs: symbol lookup error: fgfs: undefined symbol: _ZN6SGPathD1Ev
rustemy
 
Posts: 23
Joined: Fri Jun 21, 2013 1:15 pm
Version: PPA-Edge
OS: Xbuntu 17.04

Re: [2017.4.0] Unable to start FG or launcher

Postby saiarcot895 » Sun Dec 03, 2017 7:31 am

There's been no new build. There's a compile error occurring in flightgear because the code doesn't compile with the expected build dependencies; this will have to get resolved in Flightgear itself (it's not a packaging issue).
Saikrishna Arcot

My FlightGear PPAs: FlightGear Stable, FlightGear Development (Edge)
saiarcot895
 
Posts: 293
Joined: Sat Feb 02, 2013 4:26 pm
Callsign: flyhigh
Version: 2018.3.0
OS: Ubuntu 18.04

Re: [2017.4.0] Unable to start FG or launcher

Postby wkitty42 » Sun Dec 03, 2017 1:33 pm

the trick, now, is to figure out how to uninstall the broken one and install a slightly older one that works... how would that be done? how many older versions are available in the PPA?
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4539
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: [2017.4.0] Unable to start FG or launcher

Postby darkroomsource » Wed Dec 06, 2017 9:33 am

I have just done
sudo apt update
sudo apt upgrade
and now when I launch fgfs from fgrun I get
"fgfs: symbol lookup error: fgfs: undefined symbol: _ZN6SGPathD1Ev"

Is there a resolution for this?
darkroomsource
 
Posts: 2
Joined: Wed Dec 06, 2017 9:25 am

Re: [2017.4.0] Unable to start FG or launcher

Postby AndersG » Wed Dec 06, 2017 10:33 am

A library fgfs depends on have changed its public(?) interface (API or rather its binary form). You probably need to recompile fgfs or get an updated package of it.
Callsign: SE-AG
Aircraft (uhm...): Submarine Scout, Zeppelin NT, ZF Navy free balloon, Nordstern, Hindenburg, Short Empire flying-boat, ZNP-K, North Sea class, MTB T21 class, U.S.S. Monitor, MFI-9B, Type UB I submarine, Gokstad ship, Renault FT.
AndersG
 
Posts: 2404
Joined: Wed Nov 29, 2006 9:20 am
Location: Göteborg, Sweden
Callsign: SE-AG
OS: Debian GNU Linux

Re: [2017.4.0] Unable to start FG or launcher

Postby wkitty42 » Wed Dec 06, 2017 5:36 pm

read above to saiarcot895 post... they're the owner of the PPA most folks use that have to use a PPA...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4539
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5


Return to Flying

Who is online

Users browsing this forum: No registered users and 1 guest