Board index FlightGear Support Flying

Some aircrafts will not start the engines  Topic is solved

Controlling your aircraft, using the autopilot etc.

Re: Some aircrafts will not start the engines

Postby dg-505 » Wed Nov 15, 2017 7:24 pm

Thanks for the screenshot.

When you switch the External/Battery selector to "Battery" and the Battery master switch to "on":
What does this dialog window show?

Do you have any output in the console?
It's not just a hobby. I'ts a passion: FLYING !!

DHC-6 Twin Otter development
User avatar
dg-505
 
Posts: 614
Joined: Mon Jun 02, 2014 2:36 pm
Location: Hessen, Germany
Version: next
OS: Ubuntu 16.04

Re: Some aircrafts will not start the engines

Postby Harrisson » Wed Nov 15, 2017 7:42 pm

This time I managed to open FlightGear with the console (saw a tutorial in the wiki) and, well, I'll post the image (it has some nasal runtime errors)

And when I switch the power selector from external to off to battery, the dialog box rests the same.

Image
Harrisson
 
Posts: 12
Joined: Tue Nov 14, 2017 10:31 pm

Re: Some aircrafts will not start the engines

Postby dg-505 » Wed Nov 15, 2017 7:48 pm

Ah, that looks like we are getting closer!

As I don't know exactly what version of the aircraft yo use:
Can you find the file "systems.nas" and "Electrical.nas" that are mentioned in your terminal window and tell us what is in line 2 of "systems.nas" and in line 341 of "Electrical.nas"?

Or, to have a better overview, can you upload these files somewhere (maybe Google drive or something like this) and post a link to them?
It's not just a hobby. I'ts a passion: FLYING !!

DHC-6 Twin Otter development
User avatar
dg-505
 
Posts: 614
Joined: Mon Jun 02, 2014 2:36 pm
Location: Hessen, Germany
Version: next
OS: Ubuntu 16.04

Re: Some aircrafts will not start the engines

Postby Harrisson » Wed Nov 15, 2017 7:59 pm

It's here!

From the systems.nas:

#### DHC6 systems ####
aircraft.livery.init("Aircraft/dhc6/Models/Liveries"); - line 2
setprop("controls/armament/station[5]/release-all",1);
setprop("controls/armament/station[6]/release-all",0);
var C_volume = props.globals.initNode("sim/sound/cabin",0.3);
var D_volume = props.globals.initNode("sim/sound/doors",0.7);
var E1_volume = props.globals.initNode("sim/sound/engine[0]",0.0);
var E2_volume = props.globals.initNode("sim/sound/engine[1]",0.0);
var stall_volume = props.globals.initNode("sim/sound/stall-warning",0.0);
var hyd_pump_volume = props.globals.initNode("sim/sound/hyd-pump",0.0);
var ctn_counter=0;
Wiper=[];

And from the electrical.nas:

if (internal_starter < 0) { - line 341
internal_starter = -internal_starter;
starter_volts1 = bus_volts * internal_starter;
} else if (internal_starter > 0) {
starter_volts = bus_volts * internal_starter;
}

And the files:

https://www.dropbox.com/sh/b1so8l6f2inl ... cn61a?dl=0

And thank you!
Harrisson
 
Posts: 12
Joined: Tue Nov 14, 2017 10:31 pm

Re: Some aircrafts will not start the engines

Postby dg-505 » Wed Nov 15, 2017 8:14 pm

Well, strange...
I think I have solved this problem in the latest version but that was some time ago. And slowly I run out of ideas...

Can you pack the whole aircraft folder into a zip and upload it?
Maybe then I'm able to reproduce this behaviour
It's not just a hobby. I'ts a passion: FLYING !!

DHC-6 Twin Otter development
User avatar
dg-505
 
Posts: 614
Joined: Mon Jun 02, 2014 2:36 pm
Location: Hessen, Germany
Version: next
OS: Ubuntu 16.04

Re: Some aircrafts will not start the engines

Postby Harrisson » Wed Nov 15, 2017 8:20 pm

Yes, here it is

https://www.dropbox.com/s/n5f24ofc2j34vsc/dhc6.zip?dl=0

this dhc6 folder was placed in FlightGear 2017.3.1\bin\FlightGear\Aircraft\org.flightgear.fgaddon\Aircraft
Harrisson
 
Posts: 12
Joined: Tue Nov 14, 2017 10:31 pm

Re: Some aircrafts will not start the engines

Postby dg-505 » Wed Nov 15, 2017 8:32 pm

:?: It's getting strange and stranger... There are no errors in my output...

What happens when you try out this version:
https://drive.google.com/file/d/12MFvInoPZSEVRhDTEkONNWmzZYA-8fMW/view?usp=sharing

That's the latest development version, not yet published
It's not just a hobby. I'ts a passion: FLYING !!

DHC-6 Twin Otter development
User avatar
dg-505
 
Posts: 614
Joined: Mon Jun 02, 2014 2:36 pm
Location: Hessen, Germany
Version: next
OS: Ubuntu 16.04

Re: Some aircrafts will not start the engines

Postby Harrisson » Wed Nov 15, 2017 9:06 pm

This version worked perfectly.

Started it manually and with the autostart, since the beginning there where sounds I didn't heard with the other version (like the fire test sounds)

And if the other worked for you (and for another person who downloaded it and tryed) I think the problem is here (maybe some driver?)
Harrisson
 
Posts: 12
Joined: Tue Nov 14, 2017 10:31 pm

Re: Some aircrafts will not start the engines

Postby wkitty42 » Wed Nov 15, 2017 10:16 pm

extremely doubtful that some system device driver is causing this problem...

FWIW: i just tried the DHC-6-300 that is in FGAddon and it started just fine as i went through the list... t'was my first time in the craft so i don't have any ideas, either... unless possibly the OP is using an older version of FG???
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4539
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Some aircrafts will not start the engines

Postby Harrisson » Wed Nov 15, 2017 10:38 pm

Well, for me it is not just the DHC-6-300, the Citation II and the Beechcraft 1900D have the same "problem" = manual with checklist - engines don't start. Autostart = nothing happens.

I downloaded FlightGear 2017.3.1 from the website - but tried with the version 2017.2.1 with the same results.

And I remember using these planes in the past (5 to 6 months ago) without any problems.
Harrisson
 
Posts: 12
Joined: Tue Nov 14, 2017 10:31 pm

Re: Some aircrafts will not start the engines

Postby dg-505 » Thu Nov 16, 2017 5:50 am

Can you try deleting the folder $FG_Home?
Or maybe give it another name, so that you will be able to restore the settings...

For Windows the folder $FG_Home is located in:
C:\Users[{YOUR-USERNAME}\AppData\Roaming\ and it's called "flightgear.org".

You can rename it to "OLD___flightgear.org" or something like this.
This will reset all your custom settings if this was the problem
It's not just a hobby. I'ts a passion: FLYING !!

DHC-6 Twin Otter development
User avatar
dg-505
 
Posts: 614
Joined: Mon Jun 02, 2014 2:36 pm
Location: Hessen, Germany
Version: next
OS: Ubuntu 16.04

Re: Some aircrafts will not start the engines  

Postby Harrisson » Thu Nov 16, 2017 3:41 pm

Hi, nothing changes. Now I noticed that, when increasing the throttle, the levers don't move:
Image

But then I had an idea: I took the dhc6 folder from the installation folder (org.flightgear.fgaddon) and placed it in the documents folder (the one FlightGear creates).

I deleted one more time the "flightgear.org" from the Roaming folder, and then I told FlightGear to look for aircrafts in the documents... and it worked perfectly.
Harrisson
 
Posts: 12
Joined: Tue Nov 14, 2017 10:31 pm

Previous

Return to Flying

Who is online

Users browsing this forum: No registered users and 2 guests