Board index FlightGear Support Flying

Viggen update problem  Topic is solved

Controlling your aircraft, using the autopilot etc.

Viggen update problem

Postby dilbert » Wed Sep 27, 2017 1:13 pm

In most recent update can't select "red" with weapon mode selection wheel-it jumps between "ops" and "off". Consequently can't fire missiles. :(
dilbert
 
Posts: 462
Joined: Wed Jan 07, 2015 8:36 pm
Location: Alabama, USA
Callsign: db1
Version: 2018.3.2
OS: Win 10 & Chrome

Re: Viggen update problem

Postby Thorsten » Wed Sep 27, 2017 2:13 pm

It's the version for pacifists...
Thorsten
 
Posts: 10507
Joined: Mon Nov 02, 2009 8:33 am

Re: Viggen update problem

Postby Necolatis » Wed Sep 27, 2017 3:22 pm

hehe :)
RED means reduced mode and is for slow firing the cannon. Not implemented, set it to OP (operational).
"Airplane travel is nature's way of making you look like your passport photo."
— Al Gore


Hangar: https://sites.google.com/site/fghangar/
User avatar
Necolatis
 
Posts: 1906
Joined: Mon Oct 29, 2012 12:40 am
Location: EKOD
Callsign: Leto
IRC name: Neco
Version: 2018.3.2
OS: Windows 10

Re: Viggen update problem

Postby dilbert » Wed Sep 27, 2017 11:00 pm

Apparently in error assigning blame to elimination of "red".

Uninstalled update and installed older version in my hangar. Ran. Mode was "ops". Pylon was 3. armed for AA. Arming master on. Took off behind target and selected same. At gear up reticle appeared. Was in range.
Got tone. Rockets fired.

Deleted older version from my hangar and re-installed updated version from add-on hangar. Ops mode was selected. Pylon was 3, "reload air 1997" selected, Master Arming switch on. Took off behind target and selected same, using shift-n.
Target showed tail. Raised gear. Reticle never appeared. Got no tone, even with target in sight. No missile launch.

So, while absence of "red" feature is not material, am still unable to get reticle, tone, and launch rockets with updated version, and don't know why. :(

Thanks for the response and Best Regards.
dilbert
 
Posts: 462
Joined: Wed Jan 07, 2015 8:36 pm
Location: Alabama, USA
Callsign: db1
Version: 2018.3.2
OS: Win 10 & Chrome

Re: Viggen update problem

Postby Necolatis » Thu Sep 28, 2017 1:08 am

Did you press 'c' to cycle to missiles? How close to the target were you?
"Airplane travel is nature's way of making you look like your passport photo."
— Al Gore


Hangar: https://sites.google.com/site/fghangar/
User avatar
Necolatis
 
Posts: 1906
Joined: Mon Oct 29, 2012 12:40 am
Location: EKOD
Callsign: Leto
IRC name: Neco
Version: 2018.3.2
OS: Windows 10

Re: Viggen update problem

Postby dilbert » Thu Sep 28, 2017 10:33 am

No, I had manually rotated the wheel to pylon 3 with the mouse (note that pressing "c" rotates wheel in like manner).
Took off about three miles behind intended target. Had already selected 1998 armament. Arming master was on. Mode was on "op"
Following this general procedure with old version, got reticle on HUD with gear raised.
However, when raised gear in updated version, got no reticle. Approached bogey to within sight. Still no reticle, tone, etc.

Flying as I write. Just coasted in over KSFO and picked up NH0007 taking off. Shifted n and got tail on target. Gear is still up. Approached within 100 yards; then dropped back several miles. Checked my outside view. Pylons loaded for bear.
Cycled master switch off and on, but still getting no reticle on HUD, etc. :(

.
dilbert
 
Posts: 462
Joined: Wed Jan 07, 2015 8:36 pm
Location: Alabama, USA
Callsign: db1
Version: 2018.3.2
OS: Win 10 & Chrome

Re: Viggen update problem

Postby Necolatis » Thu Sep 28, 2017 7:13 pm

Did you download it through launcher?
"Airplane travel is nature's way of making you look like your passport photo."
— Al Gore


Hangar: https://sites.google.com/site/fghangar/
User avatar
Necolatis
 
Posts: 1906
Joined: Mon Oct 29, 2012 12:40 am
Location: EKOD
Callsign: Leto
IRC name: Neco
Version: 2018.3.2
OS: Windows 10

Re: Viggen update problem

Postby dilbert » Thu Sep 28, 2017 10:04 pm

Yes. I originally installed it from the add-on hangar by clicking "install". There were several updates since, all of which were incorporated by clicking "update"
while plane was in installed aircraft. However, after I encountered this problem, I clicked uninstall, after which I reinstalled from the add-on hangar by clicking "install".
No difference with problem occurred between earlier and most recent installation .

P.S. just now went to AppData.flightgear.org>aircraft and deleted the two JA-37 files present: JA37-Viggen and org.flightgear.faddon.JA37-Viggen. Then uninstalled and reinstalled the Saab JA-37 Di Viggen from the add-on hangar.
Ran. By the way-couldn't select pylon with "c" - it only went to "cannon" while still on deck. (however, I was able to cycle weapons with "c" after once airborne)
. Nevertheless, selected pylon 6 with wheel. Selected 1998 weapons from menu. Switched master arm on. Mode was on ops. Followed out and selected as target
United 720. Its icon received a tail. Took off 2 miles behind United 720. Raised gear. No reticle. No tone. And no missile launch.

Tried above leaving "cannon" selected with same result; then used "c" to get to pylon 3 once in air with same negative result. :(
dilbert
 
Posts: 462
Joined: Wed Jan 07, 2015 8:36 pm
Location: Alabama, USA
Callsign: db1
Version: 2018.3.2
OS: Win 10 & Chrome

Re: Viggen update problem

Postby Necolatis » Fri Sep 29, 2017 3:15 am

Okay, might be an error in the aircraft then. I did try to reproduce it, but it worked fine for me.
Nevertheless, I have updated it again, you should get the update probably tomorrow in the launcher.
"Airplane travel is nature's way of making you look like your passport photo."
— Al Gore


Hangar: https://sites.google.com/site/fghangar/
User avatar
Necolatis
 
Posts: 1906
Joined: Mon Oct 29, 2012 12:40 am
Location: EKOD
Callsign: Leto
IRC name: Neco
Version: 2018.3.2
OS: Windows 10

Re: Viggen update problem

Postby dilbert » Fri Sep 29, 2017 11:25 am

Thanks. Will watch for it.
Regarding my earlier remark that "c" didn't work on deck: the reason was that I had used it prior to reloading air to air.
When I reloaded air to air first, it then worked while still on deck.. Best Regards
dilbert
 
Posts: 462
Joined: Wed Jan 07, 2015 8:36 pm
Location: Alabama, USA
Callsign: db1
Version: 2018.3.2
OS: Win 10 & Chrome

Re: Viggen update problem

Postby dilbert » Sat Sep 30, 2017 7:35 pm

Regret to report no change after update. Am over Pacific 2 miles aft of United 893 as I write. Mode on OP; pylon on 6 (tried them all, by the way); gear up; reloaded air to air 1979 (tried them all) ; arming master on. No reticle, etc. Sorry.
Don't know why yours works and mine doesn't. :(


P.S. Once again uninstalled current version, added old instrument panel version to my hangar, and ran using identical
procedures. Worked like a Swiss watch.
dilbert
 
Posts: 462
Joined: Wed Jan 07, 2015 8:36 pm
Location: Alabama, USA
Callsign: db1
Version: 2018.3.2
OS: Win 10 & Chrome

Re: Viggen update problem  

Postby Necolatis » Sat Sep 30, 2017 9:10 pm

We just discovered that the master arm works opposite. Having it at OP means its off.
Will soon be fixed, sorry.
"Airplane travel is nature's way of making you look like your passport photo."
— Al Gore


Hangar: https://sites.google.com/site/fghangar/
User avatar
Necolatis
 
Posts: 1906
Joined: Mon Oct 29, 2012 12:40 am
Location: EKOD
Callsign: Leto
IRC name: Neco
Version: 2018.3.2
OS: Windows 10

Re: Viggen update problem

Postby dilbert » Sat Sep 30, 2017 11:48 pm

Glad you found it. Ran with mode in "off". Target changed from circle to square and got tone. Rockets all fired. No reticle though. Was it deliberately eliminated? Best Regards :)
dilbert
 
Posts: 462
Joined: Wed Jan 07, 2015 8:36 pm
Location: Alabama, USA
Callsign: db1
Version: 2018.3.2
OS: Win 10 & Chrome

Re: Viggen update problem

Postby Necolatis » Sun Oct 01, 2017 12:32 am

No it wasn't but it might be a second before the diamond gets showed after the tone.
"Airplane travel is nature's way of making you look like your passport photo."
— Al Gore


Hangar: https://sites.google.com/site/fghangar/
User avatar
Necolatis
 
Posts: 1906
Joined: Mon Oct 29, 2012 12:40 am
Location: EKOD
Callsign: Leto
IRC name: Neco
Version: 2018.3.2
OS: Windows 10

Re: Viggen update problem

Postby dilbert » Mon Oct 02, 2017 9:05 am

Installed latest update this morning. With mode on OP got square target and tone. But, rockets wouldn't fire. :(
dilbert
 
Posts: 462
Joined: Wed Jan 07, 2015 8:36 pm
Location: Alabama, USA
Callsign: db1
Version: 2018.3.2
OS: Win 10 & Chrome

Next

Return to Flying

Who is online

Users browsing this forum: No registered users and 4 guests