Board index FlightGear Support Flying

--livery doesn't work

Controlling your aircraft, using the autopilot etc.

--livery doesn't work

Postby LearningToFly » Sun Aug 27, 2017 4:30 pm

(I thought I ought to file this under "bug report", but the link given (2010) is broken - is this the right place?)

Just for fun, I thought I'd give my c172p some new livery.
Within the sim, yes, they all work - I pick "Select Livery" from the menu, and chose away - instant change. I'd hoped that would be a persistent property, but, alas, it appeared not.
So I thought I'd add --livery to the command line within the GUI - I tried several, I checked the names within the folder structure of the application package (I'm on OSX) - to no avail.
I often launch FG from the command line (mid-air - landing practise), so I added it there, specifically...
Code: Select all
--livery=KLM
(one that I knew worked)
Nope - same default livery.
I looked at what FG was saying in the console after my command line, in the middle of which is...
Code: Select all
   option:livery = KLM
Using default download dir: Path "/Users/roger/Library/Application Support/FlightGear"
read-allowed path not found:Path "/Users/roger/Library/Application Support/FlightGear/Liveries"
Using TerraSync dir: Path "/Users/roger/Library/Application Support/FlightGear/TerraSync"


Well, that wasn't where I'd expected it to look for liveries, but OK. So I copied the Liveries folder from the application Package into Application Support, and tried again. No error message about the folder not existing now (well, there wouldn't be), but no other error message in its place - no error messages at all.

--livery obviously hasn't gone away, since it's looking for something, but, obviously, not finding it.

Of course, maybe I'm doing something wrong, or maybe it's a bug...?
LearningToFly
 
Posts: 22
Joined: Wed Aug 16, 2017 11:22 am
Callsign: WL1890
Version: Personal
OS: OSX

Re: --livery doesn't work

Postby wkitty42 » Sun Aug 27, 2017 5:13 pm

that Liveries folder (and the AI folder) are for future use... the c172p uses Aircraft/c172p/Nasal/liveries.nas to initialize its liveries via the aircraft.livery.init() function... this way liveries are simply placed in the proper directory and they are automatically found... i have no idea if this works with the command line --livery option or not, though...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 6317
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: --livery doesn't work

Postby kaklik » Wed Apr 08, 2020 8:57 am

Is there some possibility to select specific initial livery by command-line options?
kaklik
 
Posts: 11
Joined: Fri Dec 27, 2019 7:07 pm

Re: --livery doesn't work

Postby wlbragg » Wed Apr 08, 2020 5:52 pm

On my system the current c172p livery is persistent. What version are you using?
Kansas(2-27-15)/Ohio/Midwest scenery development.
KEQA (2-27-15), 3AU, KRCP Airport Layout
Intel i5 3570K AMDRX480
User avatar
wlbragg
 
Posts: 5441
Joined: Sat Aug 25, 2012 11:31 pm
Location: Kansas (Tornado Alley), USA
Callsign: WC2020
Version: next
OS: Win10/Linux/AMDRX480

Re: --livery doesn't work

Postby kaklik » Sun Apr 12, 2020 3:49 pm

I am using the 2019.1.1 FG version, but I am able to recompile the current next version. But it works the same and --livery parameter seems to do nothing, although it is correctly parsed as input parameters. It could be seen during startup.


Code: Select all
   0.15 [INFO]:general       option:livery = followme


The followme livery I expect to apply to the jeep model. (http://wiki.flightgear.org/Jeep)
kaklik
 
Posts: 11
Joined: Fri Dec 27, 2019 7:07 pm

Re: --livery doesn't work

Postby DFaber » Mon Apr 13, 2020 9:51 am

Hi kaklik,

interesting find, I didn't knew such a commandline option exists.

kaklik wrote in Sun Apr 12, 2020 3:49 pm:I am using the 2019.1.1 FG version, but I am able to recompile the current next version. But it works the same and --livery parameter seems to do nothing, although it is correctly parsed as input parameters. It could be seen during startup.


the Option sets a property 'texture-path' under sim/model/. That is the parsed livery name with '/livery' added, which is a bit weird because the Livery directory is spelled with an upper case 'L'.
I could evaluate that during initializing at startup, but the question is what should actually happen. The Jeeps Livery definitions are more complex, than just setting the Texture. I guess the intended way is to set a texture file directly, although it may be better to load an existing Livery-definition file.

Regarding Liveries, the usual behaviour is, that a selected livery should persist to the next start. However, I found that this only works if FlightGear is exited via the Escape-Key. Just closing the Window doesn't save these Settings.

Greetings
Detlef Faber
FlightGear Development:
http://flightgear-de.net

German FlightGear Forum
http://forum.flightgear-de.net
DFaber
 
Posts: 703
Joined: Fri Dec 01, 2006 7:51 pm
Location: Aachen, Germany
Version: GIT
OS: Linux


Return to Flying

Who is online

Users browsing this forum: No registered users and 1 guest