Board index FlightGear Support Flying

problem in checklist tutorial of 777

Controlling your aircraft, using the autopilot etc.

problem in checklist tutorial of 777

Postby hamster » Mon Nov 21, 2016 12:59 am

Hi everybody!

I am getting stuck in the Checklist: Pushback/Startup tutorial in the 777-200ER aircraft (but the tutorial seems to apply to all aircraft of the 777-200 group).
When I am prompted Check: left/right/center fuel pumps ON and I enable all 6 switches the tutorial still does not continue.
I decided to debug this issue a little and found that the following properties are checked at this step:

Code: Select all
               <property>controls/fuel/tank/boost-pump</property>
               <property>controls/fuel/tank/boost-pump[1]</property>
               <property>controls/fuel/tank[1]/boost-pump</property>
               <property>controls/fuel/tank[1]/boost-pump[1]</property>
               <property>controls/fuel/tank[2]/boost-pump</property>
               <property>controls/fuel/tank[2]/boost-pump[1]</property>


Back in FlightGear I checked these values with the internal properties browser. The values of tanks "tank" and "tank[2]" were fine, but both boost pumps of "tank[1]" did not start even though their corresponding switches were enabled (which I double checked with the internal properties browser as well). Even overwriting the values
Code: Select all
               <property>controls/fuel/tank[1]/boost-pump</property>
               <property>controls/fuel/tank[1]/boost-pump[1]</property>

with "true" using the internal properties browser did not work as they were reset to false immediately.

Am I missing a prerequisite for starting the fuel pumps or is this a bug?

Best regards,

Hamster
hamster
 
Posts: 26
Joined: Tue Sep 28, 2010 6:50 pm
Location: Germany
Callsign: hamster
Version: Git
OS: Arch Linux

Re: problem in checklist tutorial of 777

Postby flightfever » Wed Dec 19, 2018 9:47 am

Hi Hamster,

It's been a good two years since you've asked this question. But someone (me) has now had another look at the issue. Simply because I ran into the same issue :D
As of the current version, 2018.03, what you describe is still the same. When running the pushback / startup checklist, it 'hangs' on switching on the fuel pumps.
And, as you state correctly, it fails on the tank[1] pumps being pushed to 'false'.

I've done a little more digging in the code and configs. It turns out that the checklist basically 'assumes' the center fuel tank is not empty. Because if it is, the systems.nas (line 1032) file will disable the two center boost-pumps. Overriding anything you try to config on them, either via switches on the OH panel, or via the property browser.

So: when configuring up your plane, and wanting to use this particular checklist, make sure to have a little fuel in the center tank, via Equipment -> fuel and payload. Then it will run smoothly, and you will end up with a 'fully' started bird.

Cheers,
flightfever
flightfever
 
Posts: 1
Joined: Wed Dec 19, 2018 9:35 am

Re: problem in checklist tutorial of 777

Postby BEL ISAAK » Thu Dec 20, 2018 5:03 pm

Hi flightfever, thanks for bringing this to my attention, I 'll take a look at it and see if I can correct it, it should be trivial as I 've done the same for the Checklist itself (which only requires L/R pumps to be activated when the center tank is empty).
User avatar
BEL ISAAK
 
Posts: 223
Joined: Sat Jun 04, 2011 2:52 pm
Location: Leuven, Belgium
Callsign: OO-ISA
Version: 2018.2.2
OS: Windows 10

Re: problem in checklist tutorial of 777

Postby BEL ISAAK » Sat Jan 12, 2019 3:05 pm

I looked into it. I've decided to redo the push&start tutorial completely, as a lot of markers are displaced and some important steps have been omitted (hydraulics, window heat, ADIRS...). It might take some time but I think it 'll be worth it.

For now, you can use the checklists system instead, it's quite complete (for the current state of the aircraft) and it received markers and bindings recently, so you can even start the 777 from within the dialog. Thanks for bringing this issue to my attention!

edit: I 've pushed a temporary fix to fgaddon in the mean time. The tutorial will not check for the center fuel pumps at all. This fixes your issue but means that when there is fuel in the center tanks, the tutorial will move on even if you didn't enable all fuel pumps. I guess that's less bad than getting stuck in the tutorial.
User avatar
BEL ISAAK
 
Posts: 223
Joined: Sat Jun 04, 2011 2:52 pm
Location: Leuven, Belgium
Callsign: OO-ISA
Version: 2018.2.2
OS: Windows 10


Return to Flying

Who is online

Users browsing this forum: No registered users and 2 guests