Board index FlightGear Support Flying

P51D startup problems

Controlling your aircraft, using the autopilot etc.

P51D startup problems

Postby Beaver » Mon Feb 15, 2016 8:27 am

So, I think I nailed the startup checklist until the first "Start switch" (everything simulated has turned green). But when pressing the start switch, the whole view/screen turns red. Only the cockpit view is red, the rest of the views are fine.

Any idea what went wrong?

Latest download and compile from svn, latest FG Addon
Beaver
 
Posts: 17
Joined: Mon Dec 21, 2015 2:27 pm

Re: P51D startup problems

Postby Johan G » Mon Feb 15, 2016 12:49 pm

Unfortunately it is a known, but so far largely unsolved problem. However, and if I recall correctly, it only occurs during certain conditions. See the for example the topic p51d-jsbsim on Start, severe compressability, screen red
Low-level flying — It's all fun and games till someone looses an engine. (Paraphrased from a YouTube video)
Improving the Dassault Mirage F1 (Wiki, Forum, GitLab. Work in slow progress)
Johan G
Moderator
 
Posts: 5377
Joined: Fri Aug 06, 2010 5:33 pm
Location: Sweden
Callsign: SE-JG
IRC name: Johan_G
Version: 3.0.0
OS: Windows 7, 32 bit

Re: P51D startup problems

Postby Ianio » Wed Mar 16, 2016 1:39 pm

i have had this too. i ended up using a startup script to get the beast up and running but as soon as i released the parking brake everything went red.

file > reset aircraft and the problem didnt repeat a second time.

that cockpit is beautifully detailed but makes my pc stutter a little. i thought maybe that was the issue but others have reported the same.
Ianio
 
Posts: 21
Joined: Sun Feb 28, 2016 11:16 am
Location: UK
Callsign: ianio
Version: 2016.1
OS: Linux Mint 17.3

Re: P51D startup problems

Postby sanhozay » Wed Mar 16, 2016 2:36 pm

This is not unique to the P51D either, although it seems to be unique to JSBSim. I have a similar problem with my Beagle Pup and wilbragg had a similar problem with the updated Cub. I think his description sums it up pretty well:

wlbragg wrote in Sat Jan 23, 2016 8:27 pm:It still has this unidentifiable problem with "super ball bounce" at low to stationary ground speed. To experience it you need to start up and slowly increase throttle to start motion. Then use the brake to stay near a "sweet spot" where it appears that the left side of the contact structure rolls over a hump. That is the visual, I can't isolate exactly what is happening. In certain circumstances it can cause the dreaded "super ball bounce" and on occasion even at startup. From what I can see the event is fairly regular or easily reproduced but I can't identify the cause. Modifying spring and dampening can reduce the effect but not remove it. My conclusion is it is a misplaced force of some sort. I have tried to eliminate other contact structure in an attempt to remove unknowns but to no avail.

In the case of the Pup, sometimes there is just a slight nudge to one side. Other times it's like it's been hit from the side by a car. On rare occasions, it gets catapulted 1000ft into the air (I guess that's "super ball bounce"). All this is with parking brake on and no engine running. I did some experiments with parking brake off at start and that seemed to help a little but it's not fixing it. It appears to be a spurious force, almost like JSBSim decides the aircraft should be in a slightly different position to where it is, but after the simulation has started. If there is any crash detection logic running it will fire. If not, the aircraft can tip over, intersect the gear at shallow angles and shoot up into the air. I also see the "hump" behaviour, like it's tripped over an invisible brick.

Pup, Cub, Mustang. Maybe it only affects aircraft named after animals? :?
sanhozay
 
Posts: 1207
Joined: Thu Dec 26, 2013 11:57 am
Location: EGNM
Callsign: G-SHOZ
Version: Git
OS: Ubuntu 16.04

Re: P51D startup problems

Postby sim » Wed Mar 16, 2016 7:28 pm

JSBSim - No start up problems on this 'un :wink:
User avatar
sim
 
Posts: 1420
Joined: Tue Jun 30, 2009 2:13 pm
Location: Shropshire England
Callsign: Fly4Fun
Version: 0.9.10 up
OS: 64 Win 10 HD6450

Re: P51D startup problems

Postby massima » Thu Aug 10, 2017 8:37 am

Something wrong with tutorials, they start but immediately finish.
User avatar
massima
 
Posts: 215
Joined: Sat Jan 03, 2015 6:48 pm
Location: Italy
Callsign: M-AXX
Version: 2018.3.2
OS: debian testing

Re: P51D startup problems

Postby legoboyvdlp » Thu Aug 10, 2017 10:32 am

I have also seen this on the ATR72-500 by Omega.
It generally catapults forward at 120 knots.

Sim, that's a lovely sound :) are those sounds the default p51 sounds?
You should post it on reddit, or if you like I'll do it for you :)
User avatar
legoboyvdlp
 
Posts: 6520
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: P51D startup problems

Postby sim » Sat Aug 12, 2017 12:15 pm

Legoboy, I wish! Not default sounds. My video soundtrack was dubbed from various P51 sounds sourced from internet.
Wouldn't it be great if all Flightgear planes did true to life sounds naturally! :wink:
Feel free to post on redit though.
User avatar
sim
 
Posts: 1420
Joined: Tue Jun 30, 2009 2:13 pm
Location: Shropshire England
Callsign: Fly4Fun
Version: 0.9.10 up
OS: 64 Win 10 HD6450


Return to Flying

Who is online

Users browsing this forum: No registered users and 1 guest