Board index FlightGear Support Hardware

mouseproblem

Joysticks, pedals, monitors.

mouseproblem

Postby henkvveldhoven » Thu Oct 17, 2019 1:01 pm

Hello, I am brand new to flight gear and have a problem with my mouse. When i click on fly the mouse can control the cockpit view and the flight control, but i cannot use the mous to click on the menu. The mouse sign has disapeared and i even cannot end the program with the mouse. i do not know what to do. there has been made a report but the problem stays. Can someone help me out. I want to look at some tutorials for starting.

thanks henkvveldhoven
henkvveldhoven
 
Posts: 5
Joined: Thu Oct 17, 2019 12:54 pm

Re: mouseproblem

Postby Johan G » Thu Oct 17, 2019 5:14 pm

FlightGear have three mouse modes you switch between with the tab key:

  • Normal mode - For clicking around in the menus and in the cockpit
  • Flight control mode - For those who do not have a joystick
  • View direction mode - For panning, zooming and moving around the viewpoint

You can read some more details on these modes in the manual, getstart.pdf, which should be within the files installed with FlightGear.
Low-level flying — It's all fun and games till someone looses an engine. (Paraphrased from a YouTube video)
Improving the Dassault Mirage F1 (Wiki, Forum, GitLab. Work in slow progress)
Johan G
Moderator
 
Posts: 5528
Joined: Fri Aug 06, 2010 5:33 pm
Location: Sweden
Callsign: SE-JG
IRC name: Johan_G
Version: 3.0.0
OS: Windows 7, 32 bit

Re: mouseproblem

Postby henkvveldhoven » Fri Oct 18, 2019 12:52 pm

Johan G wrote in Thu Oct 17, 2019 5:14 pm:FlightGear have three mouse modes you switch between with the tab key:

  • Normal mode - For clicking around in the menus and in the cockpit
  • Flight control mode - For those who do not have a joystick
  • View direction mode - For panning, zooming and moving around the viewpoint

You can read some more details on these modes in the manual, getstart.pdf, which should be within the files installed with FlightGear.

Thank you for your reaction
The problem is that I lose my mouse in the normal mode, so I cannot come into the menus. I do not know whether i should make some changes somewhere, or that my computer is not strong enough.
henkvveldhoven
 
Posts: 5
Joined: Thu Oct 17, 2019 12:54 pm

Re: mouseproblem

Postby WoodSTokk » Fri Oct 18, 2019 1:27 pm

FG hide the mouse cursor if the mouse isn't moving the last 10sec.
FG hide also the menubar after 10sec.
If you move the mouse, the cursor should be immediately visible.
If the cursor goes up to the (hidden) menubar, it should also come visible.

If that isn't working for you, please sent a mail to the dev-list with all inforamtions (hardware, FG version, OS version, GPU type and driver version, etc...)
WoodSTokk
 
Posts: 296
Joined: Tue Oct 17, 2017 2:30 pm
Location: Milky Way/Sol/Earth/Europe
Callsign: OE-WST
IRC name: WoodSTokk
Version: 2018.3.1
OS: Debian Buster/Sid

Re: mouseproblem

Postby wkitty42 » Fri Oct 18, 2019 2:30 pm

WoodSTokk wrote in Fri Oct 18, 2019 1:27 pm:FG hide the mouse cursor if the mouse isn't moving the last 10sec.
FG hide also the menubar after 10sec.

these are in-sim settings...

F10->View
[right side, bottom]
Autohide menubar
Autohide cursor in XX seconds
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5695
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: mouseproblem

Postby henkvveldhoven » Sun Oct 20, 2019 9:30 am

Helo all of you, To my great astonishment the problem is partly solved. The only way i could get out of the program was control alt delete. By doing so I noticed that the mouse sign was there, so I went on with FG and indeed i could start the help menu again and work myself through the start tutorial succesfully. By my start this morning i had to do it the same way, but i worked. !! Now I am trying to learn to taxi, which is not so simple. We keep trying.
Thanks everyone that helped me.
Henkvveldhoven
henkvveldhoven
 
Posts: 5
Joined: Thu Oct 17, 2019 12:54 pm


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest