Board index FlightGear Development AI Traffic

Taxidraw pushback bug

Intelligent, computer controlled vehicles that drive/fly over the planet!

Taxidraw pushback bug

Postby gooneybird » Sun Apr 21, 2019 6:24 pm

I've been struggling the last couple of days to get pushbacks to work at EGAA with not a lot of success but seem to have found a bug in the way Taxidraw saves "pushback Hold Point" data, they are not saved with the original co-ordinates, see below.

Image

It only seems to affect the Push back hold point nodes, the taxi nodes and parking positions are unaffected. Not sure if this could be the cause of some of the other groundnet problems though.
gooneybird
 
Posts: 2971
Joined: Sat May 31, 2008 1:57 pm

Re: Taxidraw pushback bug

Postby wkitty42 » Sun Apr 21, 2019 11:24 pm

that's interesting that it would round longitude but not latitude...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5644
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Taxidraw pushback bug

Postby gooneybird » Mon Apr 22, 2019 3:44 pm

wkitty42 wrote in Sun Apr 21, 2019 11:24 pm:that's interesting that it would round longitude but not latitude...


Yes it seems that way so far and only pushback hold points. Also if you place pushback route node very close to the hold point (which I do to stop the very long wait between pushback and taxiing) they will both be placed at the same co-ordinates!

Just tested GCRR with the same result, I'll test some more locations over the next few days as I know Taxidraw does not play nice in certain areas.
gooneybird
 
Posts: 2971
Joined: Sat May 31, 2008 1:57 pm


Return to AI Traffic

Who is online

Users browsing this forum: No registered users and 5 guests