Board index FlightGear Support Installation Windows

Flightgear 2018.2.2 Won't Start  Topic is solved

Installing FlightGear, scenery, aircraft etc. on Windows.

Re: Flightgear 2018.2.2 Won't Start

Postby Thorsten » Sun Aug 05, 2018 6:09 am

I did run dxdiag and DirectX 12 is installed and appears free of issues.


DirectX doesn't help you, FG is a multi-platform system and runs on OpenGL - that's what you need to test being properly supported by your driver.
Thorsten
 
Posts: 11106
Joined: Mon Nov 02, 2009 8:33 am

Re: Flightgear 2018.2.2 Won't Start

Postby wkitty42 » Sun Aug 05, 2018 6:36 pm

AFAIK, FG is an openGL app... i don't think directX comes into it but i may be wrong... have you checked that your video drivers are up to date?
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5700
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Flightgear 2018.2.2 Won't Start

Postby wmc » Sun Aug 05, 2018 8:39 pm

wkitty42 wrote in Sun Aug 05, 2018 6:36 pm:AFAIK, FG is an openGL app... i don't think directX comes into it but i may be wrong... have you checked that your video drivers are up to date?


Yes, drivers are latest, and OpenGL client appears to be in all the right places (SYSWOW64, system32 and directories of other applications that use it) and the Quadro card accepts both DirectX and OpenGL.

As an additional check, last night I ran with the debug console enabled. The hang occurred right as the last line ("Electrical system initialized") appeared. The odd thing was that in this config, the main screen still was "Not responding..." and all the menus and gadgets were inoperable, but as soon as I clicked the close gadget on the debug console window both it and the main FG window closed.

Last few lines of the debug console output:
------------------------------------
Reading materials from C:/Program Files/FlightGear 2018.2.3/data/Materials/regions/materials.xml
Successfully synchronized directory 'Models'
restored hashes:3378
sync of http://mpserver16.flightgear.org/scenery/Airports/L started, queue size is 25
Reading systems from Path "C:/Program Files/FlightGear 2018.2.3/data/Aircraft/c172p/Systems/systems.xml"
Initializing HUD Instrument
Reading sound sound from Path "C:/Program Files/FlightGear 2018.2.3/data/Aircraft/c172p/c172-sound.xml"
Creating subsystems took:9192
Splash screen progress binding-subsystems
FGPropertyManager::GetNode() No node found for hydro/active-norm
Volcanic activity off.
KMA20 audio panel initialized
Hobbs system stopped
Hobbs system stopped
Starter off
KI266 dme indicator #0 initialized
Primer reset to 0
Electrical system initialized
---------------------------------------

wmc
wmc
 
Posts: 18
Joined: Fri Aug 03, 2018 12:07 am

Re: Flightgear 2018.2.2 Won't Start

Postby wkitty42 » Sun Aug 05, 2018 11:45 pm

wmc wrote in Sun Aug 05, 2018 8:39 pm:Last few lines of the debug console output:
------------------------------------
Reading materials from C:/Program Files/FlightGear 2018.2.3/data/Materials/regions/materials.xml
Successfully synchronized directory 'Models'
restored hashes:3378
sync of http://mpserver16.flightgear.org/scenery/Airports/L started, queue size is 25

the lines above are sim initialization entries... the first one is loading the materials for the scenery... things like desert grasses for desert areas, sand for sandy areas and similar... the Models directory has been synced and is all up to date... the data in the Airports directory is now being worked on... the line above says there's 25 items in the queue to be downloaded...

wmc wrote in Sun Aug 05, 2018 8:39 pm:Reading systems from Path "C:/Program Files/FlightGear 2018.2.3/data/Aircraft/c172p/Systems/systems.xml"
Initializing HUD Instrument
Reading sound sound from Path "C:/Program Files/FlightGear 2018.2.3/data/Aircraft/c172p/c172-sound.xml"

the first and last lines are part of the craft loading... i think the HUD is in the sim's initialization because the c172p doesn't have a HUD even though you can turn on the generic one n the sim...

wmc wrote in Sun Aug 05, 2018 8:39 pm:Creating subsystems took:9192
Splash screen progress binding-subsystems

this is close to the end of the sim loading up... the first line says that the sim initing its subsystems took just over 9 seconds...

wmc wrote in Sun Aug 05, 2018 8:39 pm:FGPropertyManager::GetNode() No node found for hydro/active-norm

i think this is part of the craft and an error that it is looking for a property node that doesn't yet exist... it is not a bad error... the property will be created later...

wmc wrote in Sun Aug 05, 2018 8:39 pm:Volcanic activity off.

this is the sim loading...

wmc wrote in Sun Aug 05, 2018 8:39 pm:KMA20 audio panel initialized
Hobbs system stopped
Hobbs system stopped
Starter off
KI266 dme indicator #0 initialized
Primer reset to 0
Electrical system initialized

this is all the craft loading...

something else is going on... can you make the log file available? assuming you did set the --log-level=debug option in the launcher...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5700
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Flightgear 2018.2.2 Won't Start

Postby wmc » Mon Aug 06, 2018 12:15 am

wkitty42 wrote in Sun Aug 05, 2018 11:45 pm:something else is going on... can you make the log file available? assuming you did set the --log-level=debug option in the launcher...


YIKES! That really ramped up the data.

Now the last few lines look like:
---------------------------------------------
Adding flight: PH-ACH VFR EHLE EHLE 10 6/09:15:00 6/10:15:00 WEEK PH-ACH
Adding flight: PH-BVL VFR EHLE EHLE 10 6/09:30:00 6/10:30:00 WEEK PH-BVL
Adding flight: PH-EDD VFR EHLE EHLE 10 6/09:45:00 6/10:45:00 WEEK PH-EDD
Adding flight: PH-HKM VFR EHLE EHLE 10 6/10:00:00 6/11:00:00 WEEK PH-HKM
Adding flight: PH-HLM VFR EHLE EHLE 10 6/10:15:00 6/11:15:00 WEEK PH-HLM
Adding flight: PH-ISL VFR EHLE EHLE 10 6/10:30:00 6/11:30:00 WEEK PH-ISL
Adding flight: PH-UGS VFR EHLE EHLE 10 6/10:45:00 6/11:45:00 WEEK PH-UGS
Adding flight: PH-VRW VFR EHLE EHLE 10 6/11:00:00 6/12:00:00 WEEK PH-VRW
Adding flight: PH-WCU VFR EHLE EHLE 10 6/11:15:00 6/12:15:00 WEEK PH-WCU
parsing traffic schedules took:22284msec
-----------------------------------------------
wmc
 
Posts: 18
Joined: Fri Aug 03, 2018 12:07 am

Re: Flightgear 2018.2.2 Won't Start

Postby wkitty42 » Mon Aug 06, 2018 4:58 pm

that's the AI traffic being loaded... let's turn them off, for now... there's a few other things we can also turn off so let's do that as well just to lighten the load... add the following to the launcher's additional settings box, please...
Code: Select all
--disable-ai-models
--disable-ai-traffic
--disable-fgcom
--disable-random-buildings
--disable-random-objects
--disable-random-vegetation

you might also want to turn off ALS in the launcher, too... then we can work with just the basic renderer IF this is video related... or we can do that with these settings like those above...
Code: Select all
# ensure ALS is disabled
--prop:/sim/rendering/shaders/skydome=false
# ensure Rembrandt is disabled
--prop:/sim/rendering/rembrandt/enabled=false
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5700
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Flightgear 2018.2.2 Won't Start

Postby wmc » Wed Aug 08, 2018 1:50 am

wkitty42 wrote in Mon Aug 06, 2018 4:58 pm:that's the AI traffic being loaded... let's turn them off, for now... there's a few other things we can also turn off so let's do that as well just to lighten the load... add the following to the launcher's additional settings box, please...
Code: Select all
--disable-ai-models
--disable-ai-traffic
--disable-fgcom
--disable-random-buildings
--disable-random-objects
--disable-random-vegetation

you might also want to turn off ALS in the launcher, too... then we can work with just the basic renderer IF this is video related... or we can do that with these settings like those above...
Code: Select all
# ensure ALS is disabled
--prop:/sim/rendering/shaders/skydome=false
# ensure Rembrandt is disabled
--prop:/sim/rendering/rembrandt/enabled=false


Two runs, firs with the AI traffic disablement commands, and second with ALS disabled, produced the same result. Last few lines of each console output:
--------------------------------------------------
setting listener #366 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walker-animate.nas, line 2409
found trigger: loading animation for standing to position 0
found trigger: loading animation for walking to position 1
found trigger: loading animation for running to position 2
found trigger: loading animation for backwards to position 3
found trigger: loading animation for falling to position 4
found trigger: loading animation for open-parachute to position 5
found trigger: loading animation for landing to position 6
found trigger: loading animation for crashing to position 7
setting listener #367 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walker-animate.nas, line 2302
setting listener #368 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walker-animate.nas, line 2309
setting listener #369 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walker-animate.nas, line 2338
setting listener #370 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walker-animate.nas, line 2360
setting listener #371 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walker-animate.nas, line 2369
setting listener #372 in C:/Program Files/FlightGear 2018.2.3/data/Nasal/track_target.nas, line 92
setting listener #373 in C:/Program Files/FlightGear 2018.2.3/data/Nasal/dynamic_view.nas, line 436
setting listener #374 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walk.nas, line 787
setting listener #375 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walk.nas, line 789
setting listener #376 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walk.nas, line 791
setting listener #377 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walk.nas, line 793
setting listener #378 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walk.nas, line 795
setting listener #379 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walk.nas, line 797
setting listener #380 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walk.nas, line 799
setting listener #381 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walk.nas, line 801
setting listener #382 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walk.nas, line 803
setting listener #383 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walk.nas, line 805
setting listener #384 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walk.nas, line 809
setting listener #385 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walk.nas, line 813
Attaching listener to tied property /sim[0]/current-view[0]/view-number[0]
setting listener #386 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walk.nas, line 823
setting listener #387 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walk.nas, line 831
setting listener #388 in C:/Program Files/FlightGear 2018.2.3/data/Aircraft/Generic/Human/Nasal/walk.nas, line 835
----------------------------------------------------

What is the event listener #388 is for? Is it display related?
wmc
 
Posts: 18
Joined: Fri Aug 03, 2018 12:07 am

Re: Flightgear 2018.2.2 Won't Start

Postby wkitty42 » Wed Aug 08, 2018 4:10 pm

event listeners are for objects in the scene... like when the flaps should be lowered. a listener is watching the property that signals that... then the listener triggers the animation sequence to move the flaps in the scene...

please, can you make the entire log available somewhere so we can download it and take a look? looking only at the last lines is not profitable... the error may be hundreds of lines higher...

disabling the AI helps reduce the logging... disabling ALS and Rembrandt attempt to determine if the problem is video related... for now, please keep them disabled until we can determine the problem...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5700
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Flightgear 2018.2.2 Won't Start

Postby wkitty42 » Wed Aug 08, 2018 7:00 pm

i received your log... your concerns are valid and not unexpected... initial analysis does not turn up anything that is notable... i see the scenery synchronization seems to go OK... we can reduce the load a little more, too... please try using the UFO instead of the c172p... in the launcher, in the aircraft tab... i think you'll have to turn off the filtering to be able to find it... just search for UFO... it is the lightest weight craft that i know of... there is no cockpit...

i know i'm forgetting something else, too... i cannot remember what it is but it is, IIRC, related to disabling something in video... i've been trying to remember it since we got started on this but...

also, in the launcher, at the very top, the three dots "...", View command line... can you please copy all of that and paste it here... please wrap it in code tags...
eg:
Code: Select all
[code]paste here[/code]
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5700
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Flightgear 2018.2.2 Won't Start

Postby wmc » Wed Aug 08, 2018 11:35 pm

wkitty42 wrote in Wed Aug 08, 2018 7:00 pm:please try using the UFO instead of the c172p...

i know i'm forgetting something else, too... i cannot remember what it is but it is, IIRC, related to disabling something in video... i've been trying to remember it since we got started on this but...

also, in the launcher, at the very top, the three dots "...", View command line... can you please copy all of that and paste it here... please wrap it in code tags...
eg:
Code: Select all
[code]paste here[/code]


I'm a little confused on the reference to launcher and the three dots. The best I could figure was, before hitting the Fly button, Tools->View Command Line pane which showed:
Code: Select all
Options passed on the command line:
--launcher
Options set in the launcher:
--log-level=debug
--disable-ai-models
--disable-ai-traffic
--disable-fgcom
--disable-random-buildings
--disable-random-objects
--disable-random-vegetation
--prop:/sim/rendering/shaders/skydome=false
--prop:/sim/rendering/rembrandt/enabled=false
--disable-rembrandt
--enable-terrasync
--console
--prop:/nasal/local_weather/enabled=false
--metar=XXXX 012345Z 15003KT 19SM FEW072 FEW350 25/07 Q1028 NOSIG
--prop:/environment/weather-scenario=Core high pressure region
--aircraft-dir=C:/Program Files/FlightGear 2018.2.3/data/Aircraft/ufo
--aircraft=ufo
--fg-scenery=C:/Users/Nibir/Documents/FlightGear/Scenery Downloads
--fg-aircraft=C:/Users/Nibir/Documents/FlightGear/Aircraft Downloads
--airport=PHNL


If, however, you meant the content of the "Enter additional command-line arguments..."under Additional Settings in the Settings pane then:
Code: Select all
--log-level=debug
--disable-ai-models
--disable-ai-traffic
--disable-fgcom
--disable-random-buildings
--disable-random-objects
--disable-random-vegetation
# ensure ALS is disabled
--prop:/sim/rendering/shaders/skydome=false
# ensure Rembrandt is disabled
--prop:/sim/rendering/rembrandt/enabled=false


If it is something else I'll need a hint where to find it. BTW, I tried clicking on the here link above the argument list and nothing happens.

I hope it is OK to route the UFO attempt log to you in same manner as the last log file as that is what I will do after submitting this reply. By way of recap, I ran UFO with Multi-player off, Download scenery auto, default rendering, no AA with additional arguments listed above.

ADDITIONAL INFO: I've made attempts with the GPU (NVidia Control Panel settings) dedicated to graphics tasks only and to shared graphics and "computer" use, and with OpenGL rendering GPU set to either "auto-select" or the graphics card. None of these settings make a difference.

wmc
wmc
 
Posts: 18
Joined: Fri Aug 03, 2018 12:07 am

Re: Flightgear 2018.2.2 Won't Start

Postby wkitty42 » Thu Aug 09, 2018 1:08 am

on the three dots, at the very top of the launcher, above the summary tab... but your method worked fine...

i'll have to look into the "here" link... you say it is/was above the argument list? that would in the Tools->View Command Line option?

you're doing fine with the logs... i've not found anything yet... your synchronizing seems to be working fine... the UFO run use a different server and the stuff that did come in was OK and pretty fast as far as the verification of the files' checksums goes...

can you say what version of OpenGL your system has installed?

we've a mean storm rolling in... let me think about this some more... we have some other things we can poke at with our stick... we'll try them later...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5700
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Flightgear 2018.2.2 Won't Start

Postby wmc » Thu Aug 09, 2018 1:29 am

The "here" link is in the "Settings" side-bar tab of the "Start FlightGear" window, "Additional Settings" section.

OpenGL Extensions Viewer says version 4.6.

Hopefully the storm passes without incident. I'm recovering from a minor medical procedure so there is no rush needed on my account.
wmc
 
Posts: 18
Joined: Fri Aug 03, 2018 12:07 am

Re: Flightgear 2018.2.2 Won't Start

Postby wkitty42 » Thu Aug 09, 2018 2:02 pm

wmc wrote in Thu Aug 09, 2018 1:29 am:The "here" link is in the "Settings" side-bar tab of the "Start FlightGear" window, "Additional Settings" section.

ahhhhhh... ok... i forget that the launcher has a slightly newer look in 2018.3.0... that's where the three dots come in that i spoke of before... in my settings->additional settings area there are two blue links... one that opens a browser window to a page with the various command line options... the other one is another link to the resulting command line that would be sent to FG... this link may very well be broken in your version...

wmc wrote in Thu Aug 09, 2018 1:29 am:OpenGL Extensions Viewer says version 4.6.

right, right, right... i see it in your logs, now...
NVIDIA Corporation
Quadro M4000/PCIe/SSE2
4.6.0 NVIDIA 390.77
4.60 NVIDIA


wmc wrote in Thu Aug 09, 2018 1:29 am:Hopefully the storm passes without incident. I'm recovering from a minor medical procedure so there is no rush needed on my account.

it finally did pass on through... it was extremely noisy with all the flashing and banging around what with the leprechauns bowling in the clouds again...

so, back to your problem... i'm going to back way up and start over with the minimal profile... please clear out everything in your additional settings section and then paste the following in there... please continue to use the UFO...
Code: Select all
--log-level=debug
--ignore-autosave

--disable-ai-models
--disable-ai-traffic
--disable-clouds
--disable-clouds3d
--disable-distance-attenuation
--disable-horizon-effect
--disable-random-buildings
--disable-random-objects
--disable-random-vegetation
--disable-real-weather-fetch
--disable-rembrandt
--disable-sound
--disable-specular-highlight
--disable-splash-screen
--disable-terrasync

--fog-fastest
--visibility=5000

--prop:/sim/ai/enabled=0
--prop:/sim/rendering/draw-mask/clouds=false
--prop:/sim/rendering/draw-mask/aircraft=false
--prop:/sim/rendering/draw-mask/models=false
--prop:/sim/rendering/draw-mask/terrain=false
--prop:/sim/rendering/multi-sample-buffers=1
--prop:/sim/rendering/multi-samples=2
--prop:/sim/rendering/particles=0
--prop:/sim/rendering/quality-level=0
--prop:/sim/rendering/random-buildings=0
--prop:/sim/rendering/random-vegetation=0
--prop:/sim/rendering/shaders/quality-level=0
--prop:/sim/rendering/shaders/skydome=false
--prop:/sim/rendering/texture-compression=off

there will be no splash screen during this loading... only a dark blue screen... if we make it past the splash screen, these settings should result in a world that is completely void and empty other than a blueish sky area and a much lighter blueish land area... surprisingly enough, my GeForce GT730 gets 75fps in this mode but it is not fun to fly around in...

if this still crashes, please send me the new log file... i guess you probably should just attach it to an email to me instead of pasting it and going via the forum's email link... take my forum name and tack gmail.com onto the end of it for my email address...

if if doesn't crash, then we've made some headway and can start to enable things until we get it to crash again ;)
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5700
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Flightgear 2018.2.2 Won't Start

Postby wmc » Thu Aug 09, 2018 6:19 pm

The last set of commands allowed FlightGear to run. I was able to look around and "fly" the UFO a little with the keypad and mouse. I could tell this by looking around until the sun appeared then using the keypad to pitch and roll.

I've sent an email to you as well to test that I got it right so I can send you further log files or screenshots as needed without cluttering up the forum with lengthy logs etc. Thanks.

wmc
wmc
 
Posts: 18
Joined: Fri Aug 03, 2018 12:07 am

Re: Flightgear 2018.2.2 Won't Start

Postby wkitty42 » Thu Aug 09, 2018 6:51 pm

ok... i'll get to that in a bit... it is good to hear that we were able to get you to the empty world... now we'll start working on reenabling things and seeing where it breaks... i'll be back ;)
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5700
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

PreviousNext

Return to Windows

Who is online

Users browsing this forum: No registered users and 1 guest