Board index FlightGear Support Installation Windows

"Base package check failed"  Topic is solved

Installing FlightGear, scenery, aircraft etc. on Windows.

"Base package check failed"

Postby TrueNorthist » Mon Jul 01, 2013 3:41 pm

I just pulled the latest from Git but when I try to launch I get "Base package check failed: Version 2.12.0 found at D:\FlightGear\data
Version 2.11.0 is required. Please upgrade/downgrade..." etc hit a key to continue.

Why would the launcher not run the 2.12 version? Too soon/ not ready yet? Do I have to create new directories when changing from 2.11 to 2.12?
Last edited by TrueNorthist on Mon Jul 01, 2013 3:51 pm, edited 1 time in total.
Flying on fumes
User avatar
TrueNorthist
 
Posts: 155
Joined: Mon Dec 03, 2012 2:36 pm
Location: B.C. Canada
Callsign: C-CYCW
Version: 3.7 + 3.4
OS: 10/Ubu14.04

Re: "Base package check failed"

Postby Gijs » Mon Jul 01, 2013 3:50 pm

You need to rebuild Simgear/FlightGear (or grab a new binary). Program and date must always match, else you'll run into issues. You cannot just update one, without updating the other.
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400
User avatar
Gijs
Moderator
 
Posts: 9306
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 10

Re: "Base package check failed"

Postby TrueNorthist » Mon Jul 01, 2013 3:52 pm

I did grab a new binary and updated the data directory as well.
Flying on fumes
User avatar
TrueNorthist
 
Posts: 155
Joined: Mon Dec 03, 2012 2:36 pm
Location: B.C. Canada
Callsign: C-CYCW
Version: 3.7 + 3.4
OS: 10/Ubu14.04

Re: "Base package check failed"

Postby Gijs » Mon Jul 01, 2013 3:56 pm

Then either the binary is old (check its creation date) or you're starting the old fgfs.exe and not the new. Double check FG_Executable.
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400
User avatar
Gijs
Moderator
 
Posts: 9306
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 10

Re: "Base package check failed"

Postby TrueNorthist » Mon Jul 01, 2013 5:30 pm

Nah it just isn't working for some reason. I completely replaced the data file and re-downloaded the binary and it still doesn't match. I am certain the paths are correct. I am going to try again in a day or two.

Thanks Gijs.
Flying on fumes
User avatar
TrueNorthist
 
Posts: 155
Joined: Mon Dec 03, 2012 2:36 pm
Location: B.C. Canada
Callsign: C-CYCW
Version: 3.7 + 3.4
OS: 10/Ubu14.04

Re: "Base package check failed"

Postby Gijs » Mon Jul 01, 2013 5:31 pm

Where do you download the binary from? Exact link please.
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400
User avatar
Gijs
Moderator
 
Posts: 9306
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 10

Re: "Base package check failed"

Postby TrueNorthist » Tue Jul 02, 2013 12:21 am

I grabbed it at the wiki, which was down for a while today which is why I stopped trying. The following is where one gets directed at the link that is there now. http://flightgear.simpits.org:8080/job/ ... 2.11.0.exe

I haven't yet tried again but will be deleting my entire FG directory and starting fresh. Note the link says 2.11.
Flying on fumes
User avatar
TrueNorthist
 
Posts: 155
Joined: Mon Dec 03, 2012 2:36 pm
Location: B.C. Canada
Callsign: C-CYCW
Version: 3.7 + 3.4
OS: 10/Ubu14.04

Re: "Base package check failed"

Postby Gijs » Tue Jul 02, 2013 7:49 am

Ah, you grabbed the installer. Last build date June 22 (see http://flightgear.simpits.org:8080/job/ ... ler-Cmake/), so it's from before our switch to 2.12. See why I asked you to check the creation date :-)

The build server somehow failed building newer versions. I'll contact the maintainer to fix it.
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400
User avatar
Gijs
Moderator
 
Posts: 9306
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 10

Re: "Base package check failed"

Postby TrueNorthist » Tue Jul 02, 2013 2:05 pm

Thanks again Gijs!
Flying on fumes
User avatar
TrueNorthist
 
Posts: 155
Joined: Mon Dec 03, 2012 2:36 pm
Location: B.C. Canada
Callsign: C-CYCW
Version: 3.7 + 3.4
OS: 10/Ubu14.04

Re: "Base package check failed"

Postby Bravo » Wed Jul 10, 2013 11:18 pm

Hmmmm, so is there anywhere to get the 2.12 Win64-installer-CMake?
If you need anything just PM me.
User avatar
Bravo
 
Posts: 627
Joined: Mon Jun 29, 2009 7:14 pm
Location: New Jersey
Callsign: Bravo
Version: GIT
OS: Windows 7

Re: "Base package check failed"

Postby Hooray » Thu Jul 11, 2013 6:35 am

kuijfe09 and other users have reported similar issues, and I do remember seeing the same issue during the last release cycle(s) - I am currently trying to reproduce it, apparently fgdata master is pointing to 2.12 already, while SG/FG git next are still looking for 2.11 for some people (even with a full rebuild after deleting the source trees), it doesn't seem to be a local issue, I have seen users report this regardless of OS and/or scripted builds.

It seems to happen during the end of the release cycle when the version file is touched in $FG_ROOT, and when the next branches in SG/FG are set up for the release. Possibly, we may need to augment the git section in the release plan to keep these issues in mind.

Obviously, it doesn't affect people who explicitly set up tracking branches, but it seems to break setups that directly build from next and which directly check out master. I think even daveculp reported the same issue a while ago, and he's a core developer - so there probably is a real issue here, which we need to look into to understand what's going on:

Subject: download_and_compile - can't find osg libs

daveculp wrote:When fgfs tried to start, it quit with a warning that data version 2.8.0 was needed, whereas I only had 2.10.0. I did the simple fix of changing the version number in data to 2.8.0, so fgfs is happy now, however I get a console message that fgfs is operating in a 2.8.0 backward compatibility mode. That doesn't sound good. Any idea what the proper solution is?


@anybody affected by this: please try to delete the cmake cache, and if that doesn't help the whole build tree (or start afresh in a 2nd build tree for SG and FG) and report back.
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11259
Joined: Tue Mar 25, 2008 8:40 am

Re: "Base package check failed"

Postby TheTom » Thu Jul 11, 2013 8:12 am

fg/sg next and fgdata master, all have 2.12 correctly set. For fg/sg running cmake and afterwards compiling and installing should normally be enough...
TheTom
 
Posts: 321
Joined: Sun Oct 09, 2011 10:20 am

Re: "Base package check failed"

Postby Hooray » Thu Jul 11, 2013 8:19 am

I have been able to reproduce the issue using brisa's d&c script in a VM - I think it could be a cmake caching issue. I am getting a 2.11 version check with latest next, while having 2.12 fgdata - don't quite know what's going on.
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11259
Joined: Tue Mar 25, 2008 8:40 am

Re: "Base package check failed"

Postby Gijs » Thu Jul 11, 2013 10:30 am

I'm not convinced yet that the issue with the build server (which is what this topic is about) is caused by a version mismatch. Looking at the output I see no reference to versions whatsover: http://flightgear.simpits.org:8080/job/ ... 49/console
The issue seems to be with some quotation symbols.

The last build that worked had:
Code: Select all
set PATH=C:\Java7\bin;C:\Program Files (x86)\Mozilla Firefox;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\CollabNet\Subversion Server;D:\Program Files (x86)\CollabNet\Subversion Client;D:\Program Files (x86)\Embarcadero\RAD Studio\8.0\bin;C:\Users\Public\Documents\RAD Studio\8.0\Bpl;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files\TortoiseSVN\bin;C:\Program Files (x86)\Microsoft SQL Server\90\Tools\binn\;C:\Program Files (x86)\Git\cmd;C:\Program Files (x86)\Git\bin;C:\Program Files (x86)\Windows Live\Shared;D:\Program Files (x86)\CMake 2.8\bin;C:\Program Files (x86)\CMake 2.8\bin;C:\Program Files (x86)\CMake 2.8\bin;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Users\Public\Documents\RAD Studio\5.0\Bpl;"C:\Java7\bin";D:\Program Files (x86)\CMake 2.8\bin

While the first failed build suddenly read:
Code: Select all
set PATH=C:\Program Files (x86)\Java\jre7\bin;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\CollabNet\Subversion Server;D:\Program Files (x86)\CollabNet\Subversion Client;D:\Program Files (x86)\Embarcadero\RAD Studio\8.0\bin;C:\Users\Public\Documents\RAD Studio\8.0\Bpl;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files\TortoiseSVN\bin;C:\Program Files (x86)\Microsoft SQL Server\90\Tools\binn\;C:\Program Files (x86)\Git\cmd;C:\Program Files (x86)\Git\bin;C:\Program Files (x86)\Windows Live\Shared;D:\Program Files (x86)\CMake 2.8\bin;C:\Program Files (x86)\CMake 2.8\bin;C:\Program Files (x86)\CMake 2.8\bin;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Users\Public\Documents\RAD Studio\5.0\Bpl;"C:\Program Files (x86)\Java\jre7\bin";D:\Program Files (x86)\CMake 2.8\bin

With the error:
Code: Select all
\Java\jre7\bin";D:\Program Files (x86)\CMake 2.8\bin" was unexpected at this time.


I think the quotation marks around "C:\Program Files (x86)\Java\jre7\bin" should be removed, because the whole PATH line knows how to deal with spaces apparently.
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400
User avatar
Gijs
Moderator
 
Posts: 9306
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 10

Re: "Base package check failed"  

Postby Gijs » Thu Jul 11, 2013 9:37 pm

The paths have been fixed and SimGear built fine. It's now re-building the rest, so a working 2.12 binary should be available shortly.
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400
User avatar
Gijs
Moderator
 
Posts: 9306
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 10

Next

Return to Windows

Who is online

Users browsing this forum: No registered users and 2 guests