Board index FlightGear Support Installation Linux

yum install errors

Installing FlightGear, scenery, aircraft etc. on Linux systems like Ubuntu.

yum install errors

Postby OscarFG » Wed Jan 10, 2018 11:05 pm

Trying to install the FlightGear in CentOS 6.9, using FlightGear-2017.3.1-3.fc28.x86_64.rpm. But I'm getting a bunch of library dependency errors. Any ideas how to get the installation to complete?

[root@OMIA Documents]# yum install FlightGear-2017.3.1-3.fc28.x86_64.rpm
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Install Process
Examining FlightGear-2017.3.1-3.fc28.x86_64.rpm: FlightGear-2017.3.1-3.fc28.x86_64
Marking FlightGear-2017.3.1-3.fc28.x86_64.rpm to be installed
Loading mirror speeds from cached hostfile
* base: mirrors.sonic.net
* extras: mirror.sfo12.us.leaseweb.net
* updates: mirror.hmc.edu
Resolving Dependencies
--> Running transaction check
---> Package FlightGear.x86_64 0:2017.3.1-3.fc28 will be installed
--> Processing Dependency: FlightGear-data >= 2017.3.1 for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libQt5Core.so.5(Qt_5)(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libQt5Core.so.5(Qt_5.9)(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libQt5Gui.so.5(Qt_5)(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libQt5Network.so.5(Qt_5)(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libQt5Qml.so.5(Qt_5)(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libQt5Widgets.so.5(Qt_5)(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libdbus-1.so.3(LIBDBUS_1_3)(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libm.so.6(GLIBC_2.27)(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3.5)(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3.8 )(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.14)(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.18)(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.20)(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.21)(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libudev.so.1(LIBUDEV_183)(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: opengl-games-utils for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libOpenThreads.so.20()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libQt5Core.so.5()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libQt5Gui.so.5()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libQt5Network.so.5()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libQt5Qml.so.5()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libQt5Widgets.so.5()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libSimGearCore.so.2017.3.1()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libSimGearScene.so.2017.3.1()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libiaxclient.so.1()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libopenal.so.1()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libosg.so.131()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libosgDB.so.131()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libosgFX.so.131()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libosgGA.so.131()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libosgParticle.so.131()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libosgSim.so.131()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libosgText.so.131()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libosgUtil.so.131()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libosgViewer.so.131()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libplibfnt.so.1.8.5()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libplibjs.so.1.8.5()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libplibpu.so.1.8.5()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libplibpuaux.so.1.8.5()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libplibsg.so.1.8.5()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libplibul.so.1.8.5()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Processing Dependency: libudev.so.1()(64bit) for package: FlightGear-2017.3.1-3.fc28.x86_64
--> Finished Dependency Resolution
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libSimGearCore.so.2017.3.1()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libosgUtil.so.131()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: opengl-games-utils
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libstdc++.so.6(GLIBCXX_3.4.20)(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libosg.so.131()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libplibsg.so.1.8.5()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libudev.so.1(LIBUDEV_183 )(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: FlightGear-data >= 2017.3.1
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libQt5Widgets.so.5(Qt_5)(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libQt5Core.so.5()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libplibpu.so.1.8.5()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libopenal.so.1()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libplibfnt.so.1.8.5()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libQt5Network.so.5(Qt_5)(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libSimGearScene.so.2017.3.1()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libosgParticle.so.131()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libosgFX.so.131()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libosgText.so.131()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libstdc++.so.6(GLIBCXX_3.4.14)(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libOpenThreads.so.20()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libstdc++.so.6(GLIBCXX_3.4.21)(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libQt5Qml.so.5(Qt_5)(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libplibpuaux.so.1.8.5()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libQt5Gui.so.5()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libudev.so.1()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libQt5Core.so.5(Qt_5.9)(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libosgSim.so.131()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libosgViewer.so.131()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libplibul.so.1.8.5()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libQt5Network.so.5()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libplibjs.so.1.8.5()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libstdc++.so.6(CXXABI_1.3.8 )(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libQt5Core.so.5(Qt_5)(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libiaxclient.so.1()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libQt5Gui.so.5(Qt_5)(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libstdc++.so.6(CXXABI_1.3.5)(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libm.so.6(GLIBC_2.27)(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libQt5Widgets.so.5()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libosgGA.so.131()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libosgDB.so.131()(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libstdc++.so.6(GLIBCXX_3.4.18)(64bit)
Error: Package: FlightGear-2017.3.1-3.fc28.x86_64 (/FlightGear-2017.3.1-3.fc28.x86_64)
Requires: libQt5Qml.so.5()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
OscarFG
 
Posts: 2
Joined: Wed Jan 10, 2018 10:29 pm

Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest