Board index FlightGear Support Installation Linux

[Script] download_and_compile for TERRAGEAR-CS

Installing FlightGear, scenery, aircraft etc. on Linux systems like Ubuntu.

Re: [Script] download_and_compile for TERRAGEAR-CS

Postby btw » Wed Jan 18, 2012 7:51 am

Hi Clement,

Thankyou for looking at my problem.

I followed your instruction but there is a problem at step 3: " compile TerraGear-cs : sh terragear_download_and_compile.sh TERRAGEAR"

Here is the output:
Code: Select all
****************************************
*************** TERRAGEAR **************
****************************************
Initialized empty Git repository in /home/ben/FGTools/terragear-cs/.git/
remote: Counting objects: 8788, done.
remote: Compressing objects: 100% (2624/2624), done.
remote: Total 8788 (delta 6382), reused 8054 (delta 5892)
Receiving objects: 100% (8788/8788), 5.09 MiB | 1.70 MiB/s, done.
Resolving deltas: 100% (6382/6382), done.
Branch newconstruct set up to track remote branch newconstruct from origin.
Switched to branch 'newconstruct'
Already up-to-date.
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Boost version: 1.40.0
-- Found the following Boost libraries:
-- Found ZLIB: /usr/lib/libz.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- /usr/local/include
-- Looking for clock_gettime
-- Looking for clock_gettime - not found
-- Looking for clock_gettime in rt
-- Looking for clock_gettime in rt - found
-- looking for version: 2.5.0
-- Performing Test SIMGEAR_VERSION_OK
-- Performing Test SIMGEAR_VERSION_OK - Failed
CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:70 (MESSAGE):
  Could NOT find SimGear (missing: SIMGEAR_VERSION_OK)
Call Stack (most recent call first):
  CMakeModules/FindSimGear.cmake:212 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:72 (find_package)


-- Configuring incomplete, errors occurred!
sed: can't read src/Lib/TriangleJRS/Makefile: No such file or directory
 


Cheers,

Ben.
btw
 
Posts: 63
Joined: Sun Nov 06, 2011 8:53 pm

Re: [Script] download_and_compile for TERRAGEAR-CS

Postby F-JJTH » Wed Jan 18, 2012 11:12 am

Humm, the problem is simple here ;)
I see you have follow my small tips, since you are in new folder you need to run the script entirely.

Thus follow these steps :
- In your folder "FGTools" delete ALL files and folders
- In your folder "FGTools" put my script version 0.6
- Open terminal then : cd FGTools/
- Compile all : sh terragear_download_and_compile.sh -j 2 ALL

-j 2 param is for DualCore proc, if you have QuadCore use -j 4
Personnally I have a QuadCore but I use -j 12 because I don't like waiting :P

Good luck ;)
Let me know if it works

Cheers,
Clément
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: [Script] download_and_compile for TERRAGEAR-CS

Postby btw » Wed Jan 18, 2012 3:14 pm

Something still not working.

I followed your instruction and it compiled GPC232 and PLIB, but nothing else, i.e., no simgear, openscenegraph, terragear or Gui. Below are the last few lines of output.

Code: Select all
cc -O -g   -c -o gpc.o gpc.c
gpc.c: In function ‘gpc_read_polygon’:
gpc.c:1034: warning: ignoring return value of ‘fscanf’, declared with attribute warn_unused_result
gpc.c:1041: warning: ignoring return value of ‘fscanf’, declared with attribute warn_unused_result
gpc.c:1044: warning: ignoring return value of ‘fscanf’, declared with attribute warn_unused_result
gpc.c:1051: warning: ignoring return value of ‘fscanf’, declared with attribute warn_unused_result
rm -f libgenpolyclip.a
ar cr libgenpolyclip.a gpc.o
ranlib libgenpolyclip.a
ln: creating symbolic link `/usr/local/include/gpc.h': File exists



I tried to compile the missing pieces using
sh terragear_download_and_compile.sh SIMGEAR
sh terragear_download_and_compile.sh TERRAGEAR
sh terragear_download_and_compile.sh TERRAGEARGUI
but it didn't seem to work.

By the way, I'm using Ubuntu 10.04 if it means anything.

Cheers,

Ben.
btw
 
Posts: 63
Joined: Sun Nov 06, 2011 8:53 pm

Re: [Script] download_and_compile for TERRAGEAR-CS

Postby F-JJTH » Wed Jan 18, 2012 3:23 pm

Humm delete the file "/usr/local/include/gpc.h"
And verify if exist "/include/gpc.h" if exist : delete it also

Then re-compile GPC232

Please give me the complete log file ;) It contain many information I need to help you

Cheers,
Clément
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: [Script] download_and_compile for TERRAGEAR-CS

Postby btw » Wed Jan 18, 2012 5:16 pm

Hi Clement,

I deleted "/usr/local/include/gpc.h" and "/include/gpc.h" did not exist. I believe this fixed the previous problem. Still Problems at the TERRAGEAR stage. I can't include the full compilation log, it's to big. Below is the compilation log for the TERRAGEAR part, there didn't seem to be any problems with the previous parts of the installation.



Code: Select all
 
***********************************
****************************************
*************** TERRAGEAR **************
****************************************
COMPILING TERRAGEAR
INSTALL_DIR_TERRAGEAR=/home/ben/FGTools/install/terragear-cs
git clone git://gitorious.org/fg/terragear-cs.git ...  OK
RECONFIGURE TERRAGEAR-CS ...
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Boost version: 1.40.0
-- Found the following Boost libraries:
-- Found ZLIB: /usr/lib/libz.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- /home/ben/FGTools/install/simgear/include
-- Looking for clock_gettime
-- Looking for clock_gettime - not found
-- Looking for clock_gettime in rt
-- Looking for clock_gettime in rt - found
-- looking for version: 2.5.0
-- Performing Test SIMGEAR_VERSION_OK
-- Performing Test SIMGEAR_VERSION_OK - Success
-- Found SimGear: optimized;/home/ben/FGTools/install/simgear/lib/libsgephem.a;debug;/home/ben/FGTools/install/simgear/lib/libsgephem.a;optimized;/usr/local/lib/libsgsky.a;debug;/usr/local/lib/libsgsky.a;optimized;/usr/local/lib/libsgmaterial.a;debug;/usr/local/lib/libsgmaterial.a;optimized;/usr/local/lib/libsgtgdb.a;debug;/usr/local/lib/libsgtgdb.a;optimized;/usr/local/lib/libsgmodel.a;debug;/usr/local/lib/libsgmodel.a;optimized;/usr/local/lib/libsgscreen.a;debug;/usr/local/lib/libsgscreen.a;optimized;/home/ben/FGTools/install/simgear/lib/libsgnasal.a;debug;/home/ben/FGTools/install/simgear/lib/libsgnasal.a;optimized;/home/ben/FGTools/install/simgear/lib/libsgroute.a;debug;/home/ben/FGTools/install/simgear/lib/libsgroute.a;optimized;/home/ben/FGTools/install/simgear/lib/libsgtiming.a;debug;/home/ben/FGTools/install/simgear/lib/libsgtiming.a;optimized;/home/ben/FGTools/install/simgear/lib/libsgio.a;debug;/home/ben/FGTools/install/simgear/lib/libsgio.a;optimized;/home/ben/FGTools/install/simgear/lib/libsgbucket.a;debug;/home/ben/FGTools/install/simgear/lib/libsgbucket.a;optimized;/home/ben/FGTools/install/simgear/lib/libsgserial.a;debug;/home/ben/FGTools/install/simgear/lib/libsgserial.a;optimized;/home/ben/FGTools/install/simgear/lib/libsgmath.a;debug;/home/ben/FGTools/install/simgear/lib/libsgmath.a;optimized;/home/ben/FGTools/install/simgear/lib/libsgstructure.a;debug;/home/ben/FGTools/install/simgear/lib/libsgstructure.a;optimized;/home/ben/FGTools/install/simgear/lib/libsgprops.a;debug;/home/ben/FGTools/install/simgear/lib/libsgprops.a;optimized;/home/ben/FGTools/install/simgear/lib/libsgxml.a;debug;/home/ben/FGTools/install/simgear/lib/libsgxml.a;optimized;/home/ben/FGTools/install/simgear/lib/libsgmisc.a;debug;/home/ben/FGTools/install/simgear/lib/libsgmisc.a;optimized;/home/ben/FGTools/install/simgear/lib/libsgthreads.a;debug;/home/ben/FGTools/install/simgear/lib/libsgthreads.a;optimized;/home/ben/FGTools/install/simgear/lib/libsgdebug.a;debug;/home/ben/FGTools/install/simgear/lib/libsgdebug.a;optimized;/home/ben/FGTools/install/simgear/lib/libsgmagvar.a;debug;/home/ben/FGTools/install/simgear/lib/libsgmagvar.a
CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:70 (MESSAGE):
  Could NOT find GPC (missing: GPC_LIBRARY)
Call Stack (most recent call first):
  CMakeModules/FindGPC.cmake:24 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:73 (find_package)


-- Configuring incomplete, errors occurred!
btw
 
Posts: 63
Joined: Sun Nov 06, 2011 8:53 pm

Re: [Script] download_and_compile for TERRAGEAR-CS

Postby btw » Wed Jan 18, 2012 6:03 pm

Hi Clement, Further to my last post, here is the compilation log for the GPC232 section:

Code: Select all
***********************************
****************************************
*************** GPC232 *****************
****************************************
COMPILING GPC232
INSTALL_DIR_GPC=/home/ben/FGTools/install/gpc232
DOWNLOAD GPC232
UNZIP GPC232
Fix GPC_EPSILON value
CREATING MAKEFILE
MAKE GPC232
make  -j2 
cc -O -g   -c -o gpc.o gpc.c
gpc.c: In function ‘gpc_read_polygon’:
gpc.c:1034: warning: ignoring return value of ‘fscanf’, declared with attribute warn_unused_result
gpc.c:1041: warning: ignoring return value of ‘fscanf’, declared with attribute warn_unused_result
gpc.c:1044: warning: ignoring return value of ‘fscanf’, declared with attribute warn_unused_result
gpc.c:1051: warning: ignoring return value of ‘fscanf’, declared with attribute warn_unused_result
rm -f libgenpolyclip.a
ar cr libgenpolyclip.a gpc.o
ranlib libgenpolyclip.a
INSTALL GPCP232
make install
Create link to /usr/local/include/gpc.h
mkdir -p /home/ben/FGTools/install/gpc232/lib
mkdir -p /home/ben/FGTools/install/gpc232/include
install libgenpolyclip.a /home/ben/FGTools/install/gpc232/lib/libgenpolyclip.a
install gpc.h /home/ben/FGTools/install/gpc232/include/gpc.h
btw
 
Posts: 63
Joined: Sun Nov 06, 2011 8:53 pm

Re: [Script] download_and_compile for TERRAGEAR-CS

Postby F-JJTH » Wed Jan 18, 2012 6:07 pm

Hummm he is resistant :) I have modified my script (sorry... I'm not a Big Boss Programmer ;) )

Thus re-download my script (new version 0.7) and follow these steps :

You just need to recompile TerraGear-cs then terragearGUI. To do that :
1 - delete your "terragear-cs" folder and "terragearGUI" directories (situated in you FGTools directory)
2 - compile TerraGear-cs : sh terragear_download_and_compile.sh TERRAGEAR
3 - compile TerraGearGUI : sh terragear_download_and_compile.sh TERRAGEARGUI

And ... let me know if it works ;)
Thanks you for your patience !

Cheers,
Clément
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: [Script] download_and_compile for TERRAGEAR-CS

Postby btw » Wed Jan 18, 2012 7:45 pm

Nearly, TERRAGEAR compiled but still the GUI is a problem, see below for the output.


Code: Select all
****************************************
************* TERRAGEAR GUI ************
****************************************
Initialized empty Git repository in /home/ben/FGTools/terragear-gui/.git/
remote: Counting objects: 211, done.
remote: Compressing objects: 100% (209/209), done.
remote: Total 211 (delta 134), reused 0 (delta 0)
Receiving objects: 100% (211/211), 123.28 KiB, done.
Resolving deltas: 100% (134/134), done.
/home/ben/FGTools
Error processing project file: ..
btw
 
Posts: 63
Joined: Sun Nov 06, 2011 8:53 pm

Re: [Script] download_and_compile for TERRAGEAR-CS

Postby F-JJTH » Wed Jan 18, 2012 7:53 pm

Humm... I suggest you to delete TerraGearGUI directory and re-download TerraGearGUI as follow :

1 - Delete your TerraGearGUI folder
2 - compile TerraGearGUI : sh terragear_download_and_compile.sh -j 2 TERRAGEARGUI

I'm happy to know that TerraGear is compiled now ;)

Cheers,
Clément
Last edited by F-JJTH on Wed Jan 18, 2012 9:30 pm, edited 1 time in total.
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: [Script] download_and_compile for TERRAGEAR-CS

Postby btw » Wed Jan 18, 2012 8:30 pm

No change, exactly the same error and output as before.

The good news is that genapts is working, I can use it at the command line.
btw
 
Posts: 63
Joined: Sun Nov 06, 2011 8:53 pm

Re: [Script] download_and_compile for TERRAGEAR-CS

Postby F-JJTH » Wed Jan 18, 2012 9:29 pm

Ok, I've heard that TerraGearGUI have a bug actually... Gijs if you read this can you bring your experience here ?

Cheers,
Clément
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: [Script] download_and_compile for TERRAGEAR-CS

Postby F-JJTH » Wed Jan 18, 2012 9:47 pm

btw,
I think you haven't installed qt4-qmake, install it with : sudo apt-get install qt4-qmake
Then recompile TerraGearGUI :
1 - Delete your TerraGearGUI folder
2 - Compile TerraGearGUI : sh terragear_download_and_compile.sh -j 2 TERRAGEARGUI

I will add the qt4-qmake package in the install variable ;)

[EDIT] I have updated my script : I've added qt4-qmake installation. Version 0.8 [/EDIT]

Cheers,
Clément
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: [Script] download_and_compile for TERRAGEAR-CS

Postby btw » Wed Jan 18, 2012 11:34 pm

Hi Clement,

I did " sudo apt-get install qt4-qmake" but it seems it was already installed.

I downloaded your updated script ( assuming the previous links would get version 0.8, there was no link in your last post), and compiled Gui, the problem persists.

Maybe it is this problem that Gijs mentioned, I'll post on that topic and see what he has to say.

But once again, thanks for your marathon effort, I really appreciate it.

Cheers,

Ben.
btw
 
Posts: 63
Joined: Sun Nov 06, 2011 8:53 pm

Re: [Script] download_and_compile for TERRAGEAR-CS

Postby F-JJTH » Thu Jan 19, 2012 12:09 am

Ben,

Yes my script keep the same link but I update it. It's more easier : the link is always the same but the file is updated ;)

Your error come from qmake command. I spoke with Gijs on IRC and he said me that the current problem is totally other.
I need you does this test :

1 - With a terminal, go into your terragear-gui/build directory (for you it seem to be : /home/ben/FGTools/terragear-gui/build)
2 - Execute this command : qmake -Wall ..
3 - Post the result here (-Wall option is a debug option for qmake)

In one line :
Code: Select all
cd /home/ben/FGTools/terragear-gui/build && qmake -Wall ..

Can you give me your qmake version with : qmake -v

Cheers,
Clément
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: [Script] download_and_compile for TERRAGEAR-CS

Postby btw » Thu Jan 19, 2012 8:47 am

Hi Clement,

Here are the results:

qmake -v gives:
Code: Select all
QMake version 2.01a
Using Qt version 4.6.2 in /usr/lib


/home/ben/FGTools/terragear-gui/build && qmake -Wall .. gives:

Code: Select all
Error processing project file: ..
Last edited by Gijs on Thu Jan 19, 2012 9:55 am, edited 1 time in total.
Reason: You can edit your own posts ;)
btw
 
Posts: 63
Joined: Sun Nov 06, 2011 8:53 pm

PreviousNext

Return to Linux

Who is online

Users browsing this forum: YandexBot [Bot] and 1 guest