Board index FlightGear Development

Bugs in tutorials on 3.6.0 branch

FlightGear is opensource, so you can be the developer. In the need for help on anything? We are here to help you.
Forum rules
Core development is discussed on the official FlightGear-Devel development mailing list.

Bugs can be reported in the bug tracker.

Re: Bugs in tutorials on 3.6.0 branch

Postby aplund » Fri Aug 14, 2015 5:59 am

Not sure if it is useful or not, but here is some of my latest attempts with 3.6.0 and the straight-in-landing tutorial.

https://www.dropbox.com/s/cz2ak09y756es ... 4.mp4?dl=0

I use the numpad for control, which can be a bit difficult, particularly with the control centring (i.e. pressing '5'). The trim isn't set, so it's a bit of guess work when starting up.

The jerkiness in the video is due to my laptop not liking the screen capturing whilst running flight gear. (There is probably a better way of doing this).
aplund
 
Posts: 45
Joined: Sun Mar 01, 2015 12:17 pm

Re: Bugs in tutorials on 3.6.0 branch

Postby Thorsten » Fri Aug 14, 2015 6:01 am

Maybe try restarting the tutorial after crashing the tutorial spectacularly, and not adjusting any controls


I'm not sure that's even supported by the damage model. Might well be that a more realistic damage modeling like for the C-172p is persistent under a re-start -so if you break the wing, it might remain broken.

At some point you're running into the issue that FG has very limited support for re-starting the sim and that planes aren't usually designed with the capability in mind. So I wouldn't push my luck.
Thorsten
 
Posts: 10587
Joined: Mon Nov 02, 2009 8:33 am

Re: Bugs in tutorials on 3.6.0 branch

Postby aplund » Mon Aug 17, 2015 11:59 pm

I'm not sure I understand this exactly. Am I doing something wrong by restarting the tutorial after an epic fail? Should I always be restarting the entire simulator? Is this documented somewhere? I don't remember seeing it in any of the manuals/tutorials.
aplund
 
Posts: 45
Joined: Sun Mar 01, 2015 12:17 pm

Re: Bugs in tutorials on 3.6.0 branch

Postby aplund » Thu Aug 20, 2015 5:48 am

Another question I have is that when doing the takeoff tutorial, after getting the engine started properly and performing the roll along the runway, after rotating the plane banks left quite sharply. When the controls are levelled (pressing 5 on numpad) the roll continues. Is this a feature of the simulation or a bug? I don't remember it being that way in the 3.4 branch.
aplund
 
Posts: 45
Joined: Sun Mar 01, 2015 12:17 pm

Re: Bugs in tutorials on 3.6.0 branch

Postby Thorsten » Thu Aug 20, 2015 2:02 pm

A feature. A single-prop plane has non-zero prop torque and asymmetric propwash hitting the fuselage, so with controls neutral it will not go straight.

Try a warbird like the P-51D - that has really strong torque - the C-172p is harmless in comparison. Though you probably won't be able to manage a warbird with the keyboard...
Thorsten
 
Posts: 10587
Joined: Mon Nov 02, 2009 8:33 am

Re: Bugs in tutorials on 3.6.0 branch

Postby aplund » Thu Aug 20, 2015 11:02 pm

Does the C172p have aileron or rudder trim?
aplund
 
Posts: 45
Joined: Sun Mar 01, 2015 12:17 pm

Re: Bugs in tutorials on 3.6.0 branch

Postby legoboyvdlp » Fri Aug 21, 2015 2:08 am

Elevator only - again a feature. You also need either to change it through property browser or make a switch that changes the property browser property since there is no key for those AFAIK.
User avatar
legoboyvdlp
 
Posts: 6637
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: Bugs in tutorials on 3.6.0 branch

Postby aplund » Fri Aug 21, 2015 2:13 am

Sorry about all the questions, but when I start fresh and look at /controls/flight/aileron-trim is it '0.027'. I take it that's somehow reflective of reality?
aplund
 
Posts: 45
Joined: Sun Mar 01, 2015 12:17 pm

Re: Bugs in tutorials on 3.6.0 branch

Postby Thorsten » Fri Aug 21, 2015 5:12 am

When you enter a real C-172p, the trim lever is probably going to be where the last pilot left it...
Thorsten
 
Posts: 10587
Joined: Mon Nov 02, 2009 8:33 am

Re: Bugs in tutorials on 3.6.0 branch

Postby legoboyvdlp » Fri Aug 21, 2015 1:12 pm

That is a default (at least it was like that when I first downloaded it) to make it easier to fly or else harder to fky! If it is to right it will be easier woth the 172 if left it will work with P-FACTOR to make it turn left more!
User avatar
legoboyvdlp
 
Posts: 6637
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Previous

Return to Development

Who is online

Users browsing this forum: No registered users and 1 guest