Board index FlightGear Support

Severe Performance Issues with recent next  Topic is solved

All general support: help on flying, installation, hardware, getting online etc. There are lots of users and developers to help you out.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- where did you download your aircraft/scenery from?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).

Please report any bugs not specific to an aircraft on the issue tracker.
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Severe Performance Issues with recent next

Postby D-ECHO » Tue Apr 07, 2020 6:13 pm

Hey there :)

since I pulled and compiled the newest FG from next, I experience severe performance issues, with framerate dropping from 40 FPS to less than 10 (in about 2-3 minutes) while RAM usage is rising continuously to full (8GB) here and, possibly as the reason for the framerate drop, OS starts swapping from RAM.

Is there any recent addition/change that might cause this? Do others experience this as well?

If anyone needs any more diagnostics/... please just ask.

System is a Kubuntu 18.04
CPU: Intel i3-3220
RAM: DDR3 8GB
Graphics Card: NVidia GTX1050

[Update]
I noticed it only occurs when using
Code: Select all
--prop:/sim/rendering/multithreading-mode=CullDrawThreadPerContext
, so it probably does not have to do with any recent commits, but with me enabling this option a few days ago, so it's probably connected to that option, sorry for the misinformation.
User avatar
D-ECHO
 
Posts: 2080
Joined: Sat May 09, 2015 12:31 pm

Re: Severe Performance Issues with recent next

Postby wkitty42 » Tue Apr 07, 2020 7:05 pm

are you running multiple monitors?

on your update, what is that property normally on your system when you don't force it?
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 6497
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Severe Performance Issues with recent next

Postby erik » Tue Apr 07, 2020 8:27 pm

Could you try running with sound disabled, to see if that helps any.
And if so, do you have regular synthesized voices messages or morse code?

Erik
erik
 
Posts: 1593
Joined: Thu Nov 01, 2007 1:41 pm

Re: Severe Performance Issues with recent next

Postby D-ECHO » Wed Apr 08, 2020 6:03 am

wkitty42 wrote in Tue Apr 07, 2020 7:05 pm:are you running multiple monitors?

nope, just one normal window/fullscreen

wkitty42 wrote in Tue Apr 07, 2020 7:05 pm:on your update, what is that property normally on your system when you don't force it?

It is not set at all, i.e. not appearing in the property browser: Image

erik wrote in Tue Apr 07, 2020 8:27 pm:Could you try running with sound disabled, to see if that helps any.

Do you mean by disabling Master in the File -> Sound Configuration dialog? If so, no, it does not change anything, the framerate still drops with multithreading set to CullDrawThreadPerContext and still does not when not setting it.

erik wrote in Tue Apr 07, 2020 8:27 pm:And if so, do you have regular synthesized voices messages or morse code?

Voice synthesis is disabled in the File -> Sound Configuration dialog. Also, no there is no morse code sounding.

Adding to this, I just checked that this drop happens also when not flying and when not using fullscreen mode, so it probably is connected to neither of those. It's also independent from the aircraft in use (tested with an in-dev JSBSim aircraft and the ufo).

I also checked what happens when settng the multithreading property to "AutomaticSelection": In this case, the framerate drops as well.

Thank you all already for the help

[Update] The same drop in framerate happens when using CullDrawThreadPerContext (the one I originally used), AutomaticSelection, DrawThreadPerContext and CullThreadPerCameraDrawThreadPerContext (i.e. all the modes listed here http://wiki.flightgear.org/Howto:Activa ... PU_support), and also when setting it to SingleThreaded (which I thought was what is used when not setting the property at all?)

[Update] Not it even happens when not setting the property, I'm confused.
User avatar
D-ECHO
 
Posts: 2080
Joined: Sat May 09, 2015 12:31 pm

Re: Severe Performance Issues with recent next

Postby erik » Wed Apr 08, 2020 6:42 am

I was hoping you could test from the command line with the --disable-sound option:

fgfs --disable-sound

But that might make no difference after all.

Erik
erik
 
Posts: 1593
Joined: Thu Nov 01, 2007 1:41 pm

Re: Severe Performance Issues with recent next  

Postby D-ECHO » Wed Apr 08, 2020 7:05 am

Turns out the framerate drop is simply linear to more scenery tiles being loaded and has nothing at all to do with multithreading, sorry for bothering, have a good day.

@erik: --disable-sound has no influence on the performance drop
User avatar
D-ECHO
 
Posts: 2080
Joined: Sat May 09, 2015 12:31 pm

Re: Severe Performance Issues with recent next

Postby erik » Wed Apr 08, 2020 7:25 am

Ok, thanks for testing.
There is also an ongoing discussion on the mailing list about this.

Erik
erik
 
Posts: 1593
Joined: Thu Nov 01, 2007 1:41 pm

Re: Severe Performance Issues with recent next

Postby V12 » Wed Apr 08, 2020 9:08 pm

What about LOD settings ? 8GB is not enough for decent visibility limit in dense scenery.
Fly high, fly fast - fly Concorde !
User avatar
V12
 
Posts: 1819
Joined: Thu Jan 12, 2017 4:27 pm
Location: LZIB
Callsign: BAWV12

Re: Severe Performance Issues with recent next

Postby Hooray » Thu Apr 09, 2020 10:10 am

Back when the "random buildings" code received a major overhaul, we ran into a similar issue - at the time, we needed a way to monitor RAM and VRAM utilization, and we ended up patching FlightGear by adding a cross-platform library to publish CPU/RAM/SWAP and VRAM utilization in the FlightGear property tree, that way such data could also be used for "feature scaling" purposes, i.e. by hooking up the corresponding properties to a PID controller:

http://wiki.flightgear.org/Resource_Tra ... FlightGear
Image

Image
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11836
Joined: Tue Mar 25, 2008 8:40 am


Return to Support

Who is online

Users browsing this forum: No registered users and 2 guests