Board index FlightGear Support

[Solved] UFO/Input bug

All general support: help on flying, installation, hardware, getting online etc. There are lots of users and developers to help you out.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- where did you download your aircraft/scenery from?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).

Please report any bugs not specific to an aircraft on the issue tracker.
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Re: UFO/Input bug

Postby Michat » Mon Jan 27, 2020 11:56 pm

Bjoern wrote in Sat Jan 25, 2020 1:12 am: I am trying to get a more mundane workaround running, based on locking all flight control output

Hi, and thank for your research.

Using CH yoke and Thrustmaster I've suffered a lot of this crazy joystick initialization state. Not only with the ufo.

My mundane method to resolve that problem is:

1. Enter in BIOS mother board and set-check USB to highest speed mode, trivial but took over 1 day to find it.
2. When on FGinit the yoke become crazy. Unplug it, plugging again go to DEBUG and set RELOAD INPUT.
3. Still it happens?. repeat number 2 If needed do it again.
4. Still happens? Close FG and restart.

Poor of the CH yoke users that are using on windows the CH product calibration tool. Just trying to avoid crazy joystick initialization in FG. Because every time they use such tool, user will have to stress the yoke to the limits, over stressing the spring mechanism. Once you play with that tool yoke will became glitchy.

On linux does not need to calibrate so oft. Calibration tools in Linux will work better than over thousand of CH calibrations for windows.

User avatar
Posts: 1041
Joined: Mon Jan 25, 2010 6:24 pm
Location: Spain
Version: 191b
OS: GNewSense

Re: UFO/Input bug

Postby Bjoern » Sat Feb 08, 2020 3:16 am

Erik kindly created and pushed a commit to FGJoystickInput.cxx that fixes the issue for me (and one other person).

Marking the thread as solved.
Posts: 469
Joined: Fri Jan 06, 2012 10:00 pm
Location: TXL or so
Version: Next
OS: ArchLinux, Win 10


Return to Support

Who is online

Users browsing this forum: Google [Bot] and 2 guests