Board index FlightGear Support

I can't open map in external browser  Topic is solved

All general support: help on flying, installation, hardware, getting online etc. There are lots of users and developers to help you out.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- where did you download your aircraft/scenery from?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

I can't open map in external browser

Postby digitalhemmorage » Sat Apr 14, 2018 6:48 am

When i try to open the map in browser I get the message "internal web server not running. restart flightgear -httpd=8080.
I'm using window 10, Flightgear 2018, graphics card gtx 10160.
digitalhemmorage
 
Posts: 2
Joined: Sat Apr 14, 2018 6:18 am

Re: I can't open map in external browser

Postby BEL ISAAK » Sat Apr 14, 2018 11:51 am

In the additional options box in the settings page of the launcher, enter --httpd=8080 before clicking Fly.
User avatar
BEL ISAAK
 
Posts: 189
Joined: Sat Jun 04, 2011 2:52 pm
Location: Leuven, Belgium
Callsign: OO-ISA
Version: 2018.2.2
OS: Windows 10

Re: I can't open map in external browser

Postby wkitty42 » Sat Apr 14, 2018 5:01 pm

or you can use any other unused port, too... 80, 8000, 8080 and other web related ports are not set in stone... over here, we use 5500 because that's what FGRun used when we first used it and learned FGs command line options... the above message says "8080" because that's just a default that FG has for the message... 8080 definitely will not work if one is running (eg) a web proxy on it ;)

so we have "--http=5500" and we look at it via "http://our.local.machine.name.invalid:5500" when we look manually...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4732
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: I can't open map in external browser  

Postby digitalhemmorage » Tue Apr 17, 2018 2:52 am

Thank you for your help. It turns out the problem was I had quotes around my web browser command line.
--browser-app="C:\Program Files (x86)\Google\Chrome\Application\chrome.exe"
--enable-real-weather-fetch
--httpd=8080
--ceiling=750:3000 --visibility-miles=1
digitalhemmorage
 
Posts: 2
Joined: Sat Apr 14, 2018 6:18 am

Re: I can't open map in external browser

Postby wkitty42 » Tue Apr 17, 2018 3:00 pm

if it is set as the default browser, you should not need that --browser-app line at all...

TBH, this is the first i've seen/heard of it but that's not saying a lot ;)
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4732
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5


Return to Support

Who is online

Users browsing this forum: No registered users and 3 guests