Board index FlightGear Support

Hiding all notification messages (top of screen)

All general support: help on flying, installation, hardware, getting online etc. There are lots of users and developers to help you out.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- where did you download your aircraft/scenery from?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Hiding all notification messages (top of screen)

Postby phugoid » Mon Feb 01, 2016 9:32 pm

Is there a way I can hide all the messages that appear at the top of the screen? We are running FlightGear in an industrial application and we cannot show these. Some examples of what I'm referring to:
Welcome aboard! Need help? Use 'Help -> Tutorials'.
Airspeed exceeds Vne!


I'm running FlightGear 3.0.0 on Debian 8.2, installed from the Debian repository.

P.S.: This is my first post to the forum. Many thanks for the FlightGear developers - it's downright amazing how well it works with minimal fuss.
phugoid
 
Posts: 5
Joined: Mon Feb 01, 2016 9:02 pm

Re: Hiding all notification messages (top of screen)

Postby legoboyvdlp » Mon Feb 01, 2016 9:42 pm

Hello, phugoid!
Welcome to FlightGear.
How are you using it, by the way?

Well, I think the answer should be in View > View Settings -- disable the corresponding checkboxes on the right handside of the dialog. Unfortunately, I cannot load up my laptop at the moment to check it precisely, let me see if I can find an image to see which ones.

Unfortunately not.

By the way, when you figure out which checkboxes to disable, simply go to Menu > Quit to exit, as that will ensure your settings are saved. If you exit by other ways, your settings may not be saved.
Cheers!
Jonathan
User avatar
legoboyvdlp
 
Posts: 6849
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: Hiding all notification messages (top of screen)

Postby phugoid » Mon Feb 01, 2016 10:59 pm

I tried de-selecting all the right-hand column view options, and both of those messages still appear.
The welcome message shows up for a few seconds at start-up time, while the airspeed exceeded one stays on screen while the aircraft is driven at high speed (this flightgear instance is running as a slave).

We're using it in a cabin evacuation trainer. Flightgear provides fdm and visuals (one LCD monitor mounted behind each cabin window :D).
phugoid
 
Posts: 5
Joined: Mon Feb 01, 2016 9:02 pm

Re: Hiding all notification messages (top of screen)

Postby Hooray » Mon Feb 01, 2016 11:18 pm

none of those are hard-coded, those are all going through the property tree and gui.nas, so you can "disable" things there.

The higher-level features are limits.nas (or the failure manager) and the tutorial system.
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11317
Joined: Tue Mar 25, 2008 8:40 am

Re: Hiding all notification messages (top of screen)

Postby phugoid » Tue Feb 02, 2016 12:20 am

Hooray wrote in Mon Feb 01, 2016 11:18 pm:none of those are hard-coded, those are all going through the property tree and gui.nas, so you can "disable" things there.

The higher-level features are limits.nas (or the failure manager) and the tutorial system.


I would really appreciate any guidance on how to achieve this.

On the property tree side, I can't seem to find an option to switch off the messaging. What I did find was:
/nasal/tutorial/enabled='false' # yet the startup Welcome Aboard message appears
/sim/messages/* # This includes the Welcome Aboard message, but does not include the Airspeed warning

I tried commenting out the one line of code inside the popupTip() function inside of gui.nas, but this had no effect on the messages.

Sorry if I'm not seeing the obvious, this code base is completely new to me.
phugoid
 
Posts: 5
Joined: Mon Feb 01, 2016 9:02 pm

Re: Hiding all notification messages (top of screen)

Postby Thorsten » Tue Feb 02, 2016 6:53 am

Whatever is written to

/sim/messages/*

at runtime is shown on-screen for a few seconds, then moved away. When the next message is written to that node, that is moved on-screen.

So you need to run a grep for /sim/messages/ through the aircraft's Nasal file and disable all the lines which do something like

Code: Select all
setprop("/sim/messages/copilot", airspeed_string);


The tutorial message is shown if a tutorial exists, if you don't need it I think you can simply remove it from the aircraft files and the message will not be shown.
Thorsten
 
Posts: 10693
Joined: Mon Nov 02, 2009 8:33 am

Re: Hiding all notification messages (top of screen)

Postby Parnikkapore » Tue Feb 02, 2016 10:31 am

To avoid making things complicated,isn't it easier to just move the text box out of the way(e.g. Bottom edge)?
There are free alternatives to every program you encounter. You just have to find them.
Parnikkapore
 
Posts: 810
Joined: Thu Oct 29, 2015 10:16 am
Callsign: HS-FGS
Version: next [PPA]
OS: Mint 18

Re: Hiding all notification messages (top of screen)

Postby Hooray » Tue Feb 02, 2016 10:35 am

just do what we told you to do - see gui.nas and screen.nas, there's even a variable to disable the whole thing.
It takes 10 seconds to make those changes, and they will be gone for good
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11317
Joined: Tue Mar 25, 2008 8:40 am

Re: Hiding all notification messages (top of screen)

Postby Parnikkapore » Tue Feb 02, 2016 12:02 pm

Hooray,Hooray! (555) Hope you write some documentation about that variable soon. It will be useless for end users like Phugoid if they don't know about it!

P.S. I can't unscramble that good news before!
There are free alternatives to every program you encounter. You just have to find them.
Parnikkapore
 
Posts: 810
Joined: Thu Oct 29, 2015 10:16 am
Callsign: HS-FGS
Version: next [PPA]
OS: Mint 18

Re: Hiding all notification messages (top of screen)

Postby Hooray » Tue Feb 02, 2016 12:17 pm

Just follow Thorsten's advice, i.e. open $FG_ROOT/Nasal/gui.nas and screen.nas - and you will see references to the "messages" properties that Thorsten mentioned, including a "do_welcome" variable in gui.nas that can be used to disable the whole thing - you can make that use a getprop() call and default it to 1 using preferences.xml:

http://sourceforge.net/p/flightgear/fgd ... al/gui.nas
Code: Select all
var do_welcome = 1;
_setlistener("/sim/signals/fdm-initialized", func {
    var haveTutorials = size(props.globals.getNode("/sim/tutorials", 1).getChildren("tutorial"));
    gui.menuEnable("tutorial-start", haveTutorials);
    if (do_welcome and haveTutorials)
        settimer(func { setprop("/sim/messages/copilot", "Welcome aboard! Need help? Use 'Help -> Tutorials'.");}, 5.0);
    do_welcome = 0;
});


change var do_welcome = 1 to something like:
Code: Select all
var do_welcome = getprop("/sim/startup/enable-welcome-messages",1);


Then, open $FG_ROOT/Preferences.xml and navigate to /sim/startup there there, and add:
Code: Select all
<enable-welcome-messages type="bool">true</enable-welcome-messages>


Next, start up FG using --prop:/sim/startup/enable-welcome-messages=0 and that message should be gone.

You can proceed equally to disable other message - like I said, refer to screen.nas for details, it's all at the bottom of the file: http://sourceforge.net/p/flightgear/fgd ... screen.nas - see the doc string there reading:

set /sim/screen/nomap=true to prevent default message mapping
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11317
Joined: Tue Mar 25, 2008 8:40 am

Re: Hiding all notification messages (top of screen)

Postby Hooray » Tue Feb 02, 2016 1:00 pm

Parnikkapore wrote in Tue Feb 02, 2016 12:02 pm:Hope you write some documentation about that variable soon.


Note that I didn't develop that feature, and also didn't write the code - I just followed Thorsten's advice.
However, I have started a corresponding wiki article: http://wiki.flightgear.org/GUI_Messages

Feel free to get involved in reviewing/editing and improving/extending the article - even if just by adding a few screenshots of different messages.

Thank you
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11317
Joined: Tue Mar 25, 2008 8:40 am

Re: Hiding all notification messages (top of screen)

Postby phugoid » Tue Feb 02, 2016 7:39 pm

Thanks, everyone who pitched in. What worked with the least hassle was to comment out a few lines (150,151) in screen.nas:

# fgcommand("dialog-new", me.dialog.prop());
# fgcommand("dialog-show", me.namenode);

For what it's worth, setting --prop:/sim/screen/nomap=1 suppressed the welcome message but not the airspeed warning.

P.S.: Trying to post this message for the second time, it seems I've exceeded a limit...
phugoid
 
Posts: 5
Joined: Mon Feb 01, 2016 9:02 pm

Re: Hiding all notification messages (top of screen)

Postby Hooray » Tue Feb 02, 2016 9:54 pm

Those Vne messages come from a different subsystem/feature (limits.nas/failure management), what you did will work for your particular use-case, but may also cripple other GUI features.
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11317
Joined: Tue Mar 25, 2008 8:40 am

Re: Hiding all notification messages (top of screen)

Postby phugoid » Mon Feb 08, 2016 9:23 am

Thanks for the heads-up, Hooray. I will keep this in mind if any GUI features I need are missing.
phugoid
 
Posts: 5
Joined: Mon Feb 01, 2016 9:02 pm

Re: Hiding all notification messages (top of screen)

Postby Parnikkapore » Mon Feb 08, 2016 12:18 pm

Glad to hear that,Phugoid! I've never seen anybody using more than just FG's graphics in application !

Hip,hip,h•••ay! (Not the PLXML expert)
There are free alternatives to every program you encounter. You just have to find them.
Parnikkapore
 
Posts: 810
Joined: Thu Oct 29, 2015 10:16 am
Callsign: HS-FGS
Version: next [PPA]
OS: Mint 18

Next

Return to Support

Who is online

Users browsing this forum: No registered users and 1 guest