Board index FlightGear Development Aircraft Cockpit development

C172P Radio Not Muting

Discussion about creating 2d and 3d cockpits.

C172P Radio Not Muting

Postby mathieugouin » Mon Jan 29, 2018 4:26 am

Hello everyone,

I recently re-dove into FlightGear. Wow, huge improvements since I first tried it around verison 1.9.1...

I really like the ATIS voice synth. But I have experienced a strange behavior.

I was sitting in the stock aircraft C172P on the runway of my favorite airport. I tune the COM1 radio to the ATIS frequency (124.9). I activate the speaker audio with the COM1 rocker switch in the up position (SPEAKER). I hear the audio of the decoded METAR being played back (very nice!). Once I got all the information I wanted, I turn it off with the rocker SWITCH center position (OFF). At this point no more audio. I realize that the volume of the COM1 knob is brought down, so I put it back midway at roughly 50%. But as soon as I start turning it up, the ATIS is played back again, even with the COM1 in the OFF position.

Here is a screen shot explaining the issue (sorry night flying...). At this point audio was still playing despite the COM1 at OFF position.

Image

It's not a major issue, but I found it strange. Is it normal behavior? It seems that the rocker switch as the effect of adjusting the volume knob between 0 and 70% to match OFF and SPEAKER.

Let me know if you need more info.

Thanks,
Mathieu
Mathieu
mathieugouin
 
Posts: 36
Joined: Thu Jan 06, 2011 3:37 am
Location: CYHU
Callsign: MGOUIN
Version: V2018.1.1
OS: Lubuntu 18.04

Re: C172P Radio Not Muting

Postby tonghuix » Mon Jan 29, 2018 11:58 am

The above switcher only effect toggling radio sound from speaker or phone, so it's not a bug.
FG Manual Chinese Translation https://github.com/tonghuix/getstart-zh
tonghuix
 
Posts: 112
Joined: Sun Nov 29, 2015 5:11 pm
Callsign: CPA112
IRC name: tonghuix
Version: next
OS: Debian Testing

Re: C172P Radio Not Muting

Postby wkitty42 » Mon Jan 29, 2018 4:44 pm

how did the volume go down to zero when the switched was flipped to the center (off) position?

i can confirm this in the c172p that is in FGData... before loading, i went to my ~/.fgfs/aircraft-data and deleted my c172p.xml file so i would start clean... i started at EGLL and used the autostart... F12 for the radio stack, looked up EGLL radio freqs and selected 128.07, Heathrow Information... i didn't hear anything so i used my mouse (left mouse button) and toggled the COM1 switch up (ON)... i used my wheel button to click the switch back to the center position (OFF)... zoom in close and you can see the radio's volume switch jump from all the way down to about 75% up as reported...

there's more goofiness in there, too... if you flip the COM1 toggle to the center, then hover your mouse over the volume switch... roll your wheel back to turn the radio off... the display will go dark... now roll the wheel forward to turn the radio on and to turn it up all the way... you can hear the radio but the COM1 switch is still in the OFF position... they get out of sequence messing with them and you eventually have to put the COM1 in the middle (OFF) position and then start with the radio at %10 volume... then you get the COM1 switch toggling and turning the radio volume up and down again...

i also have the c172p in the development repo... it loads with the new fancy splash screens... i did the same thing as above and it also exhibits this defect... i'll make a bug report about it...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5695
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: C172P Radio Not Muting

Postby mathieugouin » Tue Jan 30, 2018 4:01 am

Just to add more to the issue:

The other rocker switches (NAV1, NAV2, ADF, DME, MKR) don't exhibit the same behavior. They seem to work normally, ie. when toggling from OFF to SPEAKER, the volume of the corresponding equipment is kept at its current value. And the audio of the nav aid identification Morse code is properly played. I tried all except MKR (the ILS approach I tried did not have marker beacon it seems...) Could be my error.

Thanks,
Mathieu
mathieugouin
 
Posts: 36
Joined: Thu Jan 06, 2011 3:37 am
Location: CYHU
Callsign: MGOUIN
Version: V2018.1.1
OS: Lubuntu 18.04

Re: C172P Radio Not Muting

Postby WoodSTokk » Tue Jan 30, 2018 10:47 am

There are more problems.
Tune VOR1 and VOR2 to working frequencies. The volume knob of VOR2 is working correctly. But the volume knob of VOR1 has no influence to the volume.
Switch on the NAV1 on audiopanel. You will hear the morse identifier of VOR1.
Turn off the NAV radio and see the needles. The needles of VOR2 are moving to center (no radio reception because its off).
But the needles of VOR1 stay in position. You will also hear the morse identifier of VOR1.
Now, turn off the COM radio. The needles of VOR1 will be centered and no more identifier on audio!?
I think there is a misstake between COM1 and NAV1.

FG 2017.3.1
WoodSTokk
 
Posts: 294
Joined: Tue Oct 17, 2017 2:30 pm
Location: Milky Way/Sol/Earth/Europe
Callsign: OE-WST
IRC name: WoodSTokk
Version: 2018.3.1
OS: Debian Buster/Sid

Re: C172P Radio Not Muting

Postby wkitty42 » Tue Jan 30, 2018 6:19 pm

the bug report for this issue is here -> https://github.com/c172p-team/c172p-detailed/issues/949
please visit and add more details so debugging and fixing the defect can be more easily handled...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5695
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5


Return to Cockpit development

Who is online

Users browsing this forum: No registered users and 1 guest