Board index FlightGear Support Installation

Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Need help getting up and running? Installing FlightGear, add-on planes, sceneries etc.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?

Please, also see Requesting Technical Help.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby remarkrv » Mon Jul 23, 2018 11:24 pm

I've been running FG 2018.2.1 which I installed on my Ubuntu 16.04LTS computer from the PPA repository. Today the software updater found a 2018.3.1 update and installed it. The update deleted version 2018.2.1 and installed FG 2018.3.1 but not the executable files and I get the old FGRun launcher when I run FG. The same thing happened when I was upgraded from FG2017.3.1 to FG2018.1.1 Eventually the needed files were installed by the updater. Hoping that is so this time.
remarkrv
 
Posts: 14
Joined: Fri Sep 21, 2007 3:17 pm
Location: Northern Indiana
Version: 2017.3.1
OS: Ubuntu Linux

Re: Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby wkitty42 » Tue Jul 24, 2018 3:42 pm

2018.3.1 has not been release yet... there's still a few more weeks for it to bake... 2018.2.3 was just packaged and released, though... i don't know if saiarcot895's PPA has had time to update, build and package it, yet, though... this only just happened around 1300UTC on 24 July 2018...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5634
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby saiarcot895 » Tue Jul 24, 2018 4:30 pm

As wkitty42 said, 2018.3.1 isn't released yet. I'm in the process of uploading 2018.2.2, and because of these delays, these issues are happening (I wish there was a reliable way to explicitly tell package managers not to update the data package if it means removing the executables).

I'm hoping to have this resolved by tomorrow.
Saikrishna Arcot

My FlightGear PPAs: FlightGear Stable, FlightGear Development (Edge)
saiarcot895
 
Posts: 305
Joined: Sat Feb 02, 2013 4:26 pm
Callsign: flyhigh
Version: 2018.3.0
OS: Ubuntu 18.04

Re: Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby gsagostinho » Tue Jul 24, 2018 8:42 pm

Thank you so much, saiarcot895
User avatar
gsagostinho
 
Posts: 1800
Joined: Thu Jan 15, 2015 6:27 pm
Location: London, UK

Re: Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby gsagostinho » Wed Jul 25, 2018 10:15 pm

I just managed to re-install flightgear using this PPA, thanks a lot for taking a look at this!
User avatar
gsagostinho
 
Posts: 1800
Joined: Thu Jan 15, 2015 6:27 pm
Location: London, UK

Re: Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby jjcase337 » Thu Jul 26, 2018 4:29 pm

Hello And Firstly thanks for all the work/dedication you all put into this sim. Something happened around the same day you guys are talking about the update to 2018.3.1, I think I had that notification, unless it was 2.1, not sure what version but i updated using the update manager, then i began having all kind of issues. First I tried to reinstall flightgear a couple times different ways. Tried throught package manager and also software manager, but I never could get my qt launcher back up, and whats worst i lost my joystick detection in FGFS. I have tried also to remove every file directory at one point and reinstalled, ran sudo updates, upgrades, cleared caches, changed ppa, etc. Sorry for rambling on, so now still at version 2018.2.1 and still going straight to game with only Cessna, and no clue about the joystick. I even tried fgrun, but game wasnt starting that way. Also i know Mint detects the stick, I've used jstest-gtk and also used commands here at http://wiki.flightgear.org/Input_device#Linux. Last but not least I created another profile thinking maybe I could install flightgear to that one but still same issues persist. Any idea are should i wait? Thanks if anyone can respond!

p.s. I can't reinstall Mint Sylvia xfce until I rewrite it on another usb live stick, so I'm hoping its not anything in my linux build corrupted.
Josh
jjcase337
 
Posts: 8
Joined: Sat Mar 10, 2018 1:15 pm
Location: Lafayette, LA
Callsign: CaseAir
Version: 2018.2.2
OS: Linux Mint Sylvia

Re: Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby remarkrv » Thu Jul 26, 2018 7:52 pm

As I initially reported I went from a working FG2018.2.1 version to a botched FG2018.3.1. I was able to get FG2018.2.2 installed and working as before with terminal commands: sudo apt install --reinstall flightgear . Software updater is now telling me I have 1516.5Mb of Flightgear software available to download. Don't think I'll go there yet.
remarkrv
 
Posts: 14
Joined: Fri Sep 21, 2007 3:17 pm
Location: Northern Indiana
Version: 2017.3.1
OS: Ubuntu Linux

Re: Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby jjcase337 » Thu Jul 26, 2018 8:07 pm

hey thx, I believe i had tried some reinstall commands too, but I sure will try it again and see what happens. If that wont fix something, maybe I'll just wait a while before reinstalling, but im not sure if I messed something up in flightgear or my 18.3 Sylvia Mint build! I did get the v19, so maybe its time to upgrade anyhow...Good luck all. Peace out. 8)

Edit: Tried the reinstall command, it looked like it reinstalled, but qt launcher still missing and no joystick showing up in game at all. Is their any reason to not upgrade to higher fgfs version, because i dont know how else to get one, besides trying a different ppa? Also I installed flightgear in windows 10, so i might just have to dreadfully run it there, but im not digging it so far, hehe. Anywway, thx if aNYONe has feedback, appreciate it! My images below of two issues.

https://ibb.co/h0KjPT and other problem here https://ibb.co/cKHhB8

also last thing I just tried at final reinstall attemp and also applied one update called simgear 1:2018.3.0~5085 construction gear thingy, update manager suggested it after reinstalling from terminal. Don't know how to post the terminal here, Sorry..Still the same issues.....At the moment Im playing it in windows 10, which i dont care to do, but it appears to run fine for now, with only minor differences and not much space, but we'll see, back to the drawing board and stopping windows 10 updates, hehe..
jjcase337
 
Posts: 8
Joined: Sat Mar 10, 2018 1:15 pm
Location: Lafayette, LA
Callsign: CaseAir
Version: 2018.2.2
OS: Linux Mint Sylvia

Re: Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby jjcase337 » Fri Jul 27, 2018 2:52 pm

hello again
I thought I could just downgrade everything back to all 2018.2.1 packages, but the main ones included with synamtic package manager are only 2018.3.1 ! So I only got as far as downgrading the core and scene packages. They still have ai,aircrafts,all,base, and model package files are all the new 2018.3.1 version in the manager. I think this is maybe the linux mint problem that messed up the game all a sudden. If it isn't then im really lost and my few years with linux is in vain, because another one of my favorite linux go to programs isnt working, so Windows 10 for now :(

For now, completely removing anything that says V.2018.3.0 on this manager untill i can manually get back to all 2018.2.1 packages, but even after deleting them just now, the game is still loading, so it must still have some files remaining in core of game. I don't get what made the joystick completely undetectable in game only and the launcher disapeared at start. But, now game runs without any of the 2018.3.1 packages removed. Confusing....Will take any advice about linux build or game at this point. :oops: image: https://ibb.co/fMHCDo
jjcase337
 
Posts: 8
Joined: Sat Mar 10, 2018 1:15 pm
Location: Lafayette, LA
Callsign: CaseAir
Version: 2018.2.2
OS: Linux Mint Sylvia

Re: Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby saiarcot895 » Fri Jul 27, 2018 4:06 pm

Hi,

As far as I know, and based on the flightgear home page, 2018.3.1 has NOT been released yet, and 2018.3.1 is not present in my PPAs. If you mean 2018.3.0, that is the development version, and is in my Flightgear Development PPA. I recommend you have only one of the two PPAs activated at any time. If you want the stable release, you should have 2018.2.2 packages installed (do not have 2018.3.0 packages installed).

For Linux Mint 18 (based on Ubuntu 16.04) and Linux Mint 19 (based on Ubuntu 18.04), you should be able to get the Qt launcher by starting from the menu.

jjcase337, can you give me the output of "apt-cache policy flightgear flightgear-data-all flightgear-data-base", so that I can see what versions you have installed and what versions are available?
Saikrishna Arcot

My FlightGear PPAs: FlightGear Stable, FlightGear Development (Edge)
saiarcot895
 
Posts: 305
Joined: Sat Feb 02, 2013 4:26 pm
Callsign: flyhigh
Version: 2018.3.0
OS: Ubuntu 18.04

Re: Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby jjcase337 » Fri Jul 27, 2018 4:31 pm

Code: Select all
josh@josh-KT381AA-ABA-SR5502FH ~ $ apt-cache policy flightgear flightgear-data-all flightgear-data-base
flightgear:
  Installed: (none)
  Candidate: 1:2018.3.0~13598+gitcf09e3f13-0ubuntu1~ppa1~16.04.1
  Version table:
     1:2018.3.0~13598+gitcf09e3f13-0ubuntu1~ppa1~16.04.1 500
        500 http://ppa.launchpad.net/saiarcot895/flightgear-edge/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status
     1:2018.2.2-0ubuntu1~ppa1~16.04.1 500
        500 http://ppa.launchpad.net/saiarcot895/flightgear/ubuntu xenial/main amd64 Packages
     3.4.0-3ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
     3.4.0-3 500
        500 http://archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
flightgear-data-all:
  Installed: (none)
  Candidate: 1:2018.3.0~8553+gitdb7a9b4c+dfsg-0ubuntu1~ppa1
  Version table:
     1:2018.3.0~8553+gitdb7a9b4c+dfsg-0ubuntu1~ppa1 500
        500 http://ppa.launchpad.net/saiarcot895/flightgear-edge/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/saiarcot895/flightgear-edge/ubuntu xenial/main i386 Packages
     1:2018.2.2+dfsg-0ubuntu1~ppa7 500
        500 http://ppa.launchpad.net/saiarcot895/flightgear/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/saiarcot895/flightgear/ubuntu xenial/main i386 Packages
     3.4.0+dfsg-1 500
        500 http://archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://archive.ubuntu.com/ubuntu xenial/universe i386 Packages
flightgear-data-base:
  Installed: (none)
  Candidate: 1:2018.3.0~8553+gitdb7a9b4c+dfsg-0ubuntu1~ppa1
  Version table:
     1:2018.3.0~8553+gitdb7a9b4c+dfsg-0ubuntu1~ppa1 500
        500 http://ppa.launchpad.net/saiarcot895/flightgear-edge/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/saiarcot895/flightgear-edge/ubuntu xenial/main i386 Packages
     1:2018.2.2+dfsg-0ubuntu1~ppa7 500
        500 http://ppa.launchpad.net/saiarcot895/flightgear/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/saiarcot895/flightgear/ubuntu xenial/main i386 Packages
     3.4.0+dfsg-1 500
        500 http://archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://archive.ubuntu.com/ubuntu xenial/universe i386 Packages
josh@josh-KT381AA-ABA-SR5502FH ~ $
Hey Thanks for the so soon reply, that was fast :)


I think i did have several ppa, also at one time added the your personnal ppa named myppa. Heres a sceenshot of my ppas as of right now. I will also try and start from the game menu, the Qt launcher. Thanks a bunch for helps !!!

screenshot: https://ibb.co/fvbvio

P.S. > I also have deleted anything in package manager that says 2018.3.0 and next I can delete or uncheck ppa that I dont need are causing a conflict and try again something else. But for now, it works ok in windows, just I have other issues with windows, well many other games on my ssd that I dont really know if ill be keeping for long. I do have other HDD but its old, so I rather FGFS on my Fast SSD Linux ext.4 partition.. I noticed your into chromium builds? im using SRware but might switch soon to Chromium again. Thx again sir! ~salute
jjcase337
 
Posts: 8
Joined: Sat Mar 10, 2018 1:15 pm
Location: Lafayette, LA
Callsign: CaseAir
Version: 2018.2.2
OS: Linux Mint Sylvia

Re: Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby saiarcot895 » Fri Jul 27, 2018 4:40 pm

My personal ppa (myppa) doesn't have anything related to flightgear there, and the packages there are a bit old now, I think.

So since you have both flightgear and flightgear-edge PPAs, I recommend you disable the flightgear-edge PPA (so that you're on the stable releases), update your repository, and then install flightgear.
Saikrishna Arcot

My FlightGear PPAs: FlightGear Stable, FlightGear Development (Edge)
saiarcot895
 
Posts: 305
Joined: Sat Feb 02, 2013 4:26 pm
Callsign: flyhigh
Version: 2018.3.0
OS: Ubuntu 18.04

Re: Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby jjcase337 » Fri Jul 27, 2018 5:55 pm

Ok :) Thanks, I will do as you state and hope for the best soon! I was just thinking before I do all that should maybe start from stratch and remove every possible trace of flightgear, and then from their go with a version that worked before like 2018.2.1 on this old computer. Ill try something out today soon, maybe try with your suggestion then update, upgrade , then reinstall first.. Thank you Saiarcot895, again!!

UPDATE: https://ibb.co/gv734T and https://ibb.co/i9tUB8

This photo means success finally :) .. I deleted everything all packages one last time, then deleted .fgfs and another flightgear folder, and then reinstalled only from the package manager, and BAMMMM, it looks good to go now! Thanks so much, will keep posted... :lol:

Update again: Game still working excellent at version 2018.2.2 :D . Also flirt with using newest version on same p.c. in windows to compare the two in game...
jjcase337
 
Posts: 8
Joined: Sat Mar 10, 2018 1:15 pm
Location: Lafayette, LA
Callsign: CaseAir
Version: 2018.2.2
OS: Linux Mint Sylvia

Re: Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby alicea » Tue Jan 08, 2019 10:23 pm

Tried to upgrade my FG from 2018.1 to 2018.3. DISASTER!
TOTAL MESS in the repo! Required e.g. flightgear-data-all >= 1:2018.2.2 but < 1:2018.2.3 LOL both not found, because don't exist!
I don't know WHAT THE HELL made me upgrade from 2018.1 to the newest version! Now deleted the RECOMMENDED on the website saiarcot895's repo and installing the 3.0 version from standard repos. IS IT NORMAL that the devs don't take care at all?? Dear devs! Simple .deb files needed, not the wrong path to non-working repo! Thanks in advance! BTW: the sources don't build.

A message to the people who have working FG: "DON't update, don't upgrade, just enjoy flying"
alicea
 
Posts: 5
Joined: Fri Jun 22, 2018 11:49 am
Location: EPGD
Version: 2018.1.1
OS: Mint

Re: Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby legoboyvdlp » Tue Jan 08, 2019 11:14 pm

The fact that 99% of the rest of the users had no trouble is indicative that the problem may be more between the desk and the chair than a problem with FlightGear...

I'll let others who use linux help you with debugging this...

Bear in mind that 2018.3.1 will always require 2018.3.1 data - any other version will not be compatiable.
User avatar
legoboyvdlp
 
Posts: 7001
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Next

Return to Installation

Who is online

Users browsing this forum: No registered users and 3 guests