Search found 8 matches: HiDPI

Return to advanced search

Re: Flightgear source code terminates in GLExtension.cpp

The thing to keep in mind here is that the issue is unrelated to Qt/QQ2 - it's because of the HiDPI changes that end up using newer OSG functionality that may not yet available - I haven't build fgfs in months, so my info may be outdated here - however, last I checked, ...
by Hooray
Sat Sep 15, 2018 4:09 pm
 
Forum: Compiling
Topic: Flightgear source code terminates in GLExtension.cpp
Replies: 17
Views: 2503

Re: osg::GLExtensions has not been declared

My impression here is that most of the frustration is due to people not using any HiDPI/Qt5 functionality, still being affected by attempts to make it work, despite not even linking it in - thus, the troubleshooting part is actually not obvious to people not closely ...
by Hooray
Sun Dec 31, 2017 3:30 pm
 
Forum: Compiling
Topic: osg::GLExtensions has not been declared
Replies: 46
Views: 7220

Re: osg::GLExtensions has not been declared

... particular problem would even show up in non-Qt builds, simply because it touches existing PUI related functionality, that was changed to suit HiDPI/QtQuick related improvements. Imagine it like touching an ALS shader to help improve Rembrandt - you would be affected even without having to ...
by rominet
Sun Dec 31, 2017 2:37 pm
 
Forum: Compiling
Topic: osg::GLExtensions has not been declared
Replies: 46
Views: 7220

Re: osg::GLExtensions has not been declared

... particular problem would even show up in non-Qt builds, simply because it touches existing PUI related functionality, that was changed to suit HiDPI/QtQuick related improvements. Imagine it like touching an ALS shader to help improve Rembrandt - you would be affected even without having to ...
by Hooray
Sun Dec 31, 2017 12:03 pm
 
Forum: Compiling
Topic: osg::GLExtensions has not been declared
Replies: 46
Views: 7220

Re: osg::GLExtensions has not been declared

... chance to update dependencies more aggressively (well once in a while). EDIT: I have documented the necessary steps to revert the corresponding HiDPI commits and end up with a build environment where OSG 3.2.1 can be used again: http://wiki.flightgear.org/Howto:Building_FlightGear_without_HiDPI_support ...
by Hooray
Sun Dec 31, 2017 11:10 am
 
Forum: Compiling
Topic: osg::GLExtensions has not been declared
Replies: 46
Views: 7220

Re: osg::GLExtensions has not been declared

James committed code to fix HiDPI scaling in some contexts. This seems to cause problems with OSG 3.2, otherwise what is this thread about? James then tried to fix these problems and found hurdles doing so, that's all I said and I don't ...
by rominet
Sun Dec 31, 2017 10:56 am
 
Forum: Compiling
Topic: osg::GLExtensions has not been declared
Replies: 46
Views: 7220

Re: osg::GLExtensions has not been declared

well, according to the commits, the new code is using APIs to do QtQuick/HiDPI related things, probably in response to the launcher related scaling issues discussed on the devel list at the time. These were apparently raised by i4dnf and xDraconian- i.e. the ...
by Hooray
Sun Dec 31, 2017 10:52 am
 
Forum: Compiling
Topic: osg::GLExtensions has not been declared
Replies: 46
Views: 7220

Re: osg::GLExtensions has not been declared

I have to agree with Thorsten. Actually, I can even confirm that if I revert the HiDPI/QtQuick related changes to CanvasWidget.cxx and the ones introducing PUICamera.cxx (to make PUI optional during build time) , that FlightGear does again build properly using OSG ...
by Hooray
Sun Dec 31, 2017 10:39 am
 
Forum: Compiling
Topic: osg::GLExtensions has not been declared
Replies: 46
Views: 7220

Return to advanced search

cron