Board index FlightGear Development Aircraft

FG 3.0 747-400 Autopilot

Questions and discussion about creating aircraft. Flight dynamics, 3d models, cockpits, systems, animation, textures.

Re: FG 3.0 747-400 Autopilot

Postby sanhozay » Tue Mar 04, 2014 5:09 pm

Gijs wrote in Tue Mar 04, 2014 4:38 pm:Auto throttle isn't handled by 747-400.xml, so I'd be suprised if there was any change on that aspect...

I'll do some more testing but it may be that speed control is broken in 3.0 with that file or without. Perhaps something to do with IAS vs Mach?

On my current test the speed is set to 250 and I'm just waiting to see if this 747 can break the sound barrier - Mach 0.975 as I write ...
sanhozay
 
Posts: 238
Joined: Thu Dec 26, 2013 11:57 am
Location: EGNM
Callsign: G-SHOZ, EGGP_TW
Version: Git
OS: Xubuntu 13.10

Re: FG 3.0 747-400 Autopilot

Postby Lydiot » Tue Mar 04, 2014 5:10 pm

azims wrote in Tue Mar 04, 2014 5:03 pm:Gijs,

Thanks as always for your response. I will replace the 747-400.xml from the old version.

And no need to be sorry - you are doing an awesome job!


So what is new in the updated 747-400 version? I'm just asking because I know what the problems are with the "old" one, and if I'm going to be copying the .xml from the old one, what am I gaining in the new one?
Lydiot
 
Posts: 234
Joined: Tue Oct 22, 2013 10:50 pm

Re: FG 3.0 747-400 Autopilot

Postby buster » Tue Mar 04, 2014 7:00 pm

Hallo,

I'm not involved in the further development of the 747-400 so I didn't know what has changed.
I could do the new tuning of the AP when I can be sure the changings in FDM are finished and final.
The tuning can take a while, because they must be done for several sets of flight-variables as weight, speed, CoG, altitude.

So I will wait for the final FDM before beginning adjustments.

bye, Markus
buster
 
Posts: 11
Joined: Fri Oct 18, 2013 5:53 pm

Re: FG 3.0 747-400 Autopilot

Postby Gijs » Tue Mar 04, 2014 7:12 pm

Hi Markus,

I didn't ask you to tune it yet, because the FDM is still undergoing major changes. Your offer is appreciated though, I'll definitely let you know when the FDM is "done". Hopefully before 3.2 that is.

sanhozay wrote in Tue Mar 04, 2014 5:09 pm:I'll do some more testing but it may be that speed control is broken in 3.0 with that file or without. Perhaps something to do with IAS vs Mach?

I did change the autothrottle behaviour slightly, but that's handled outside 747-400.xml. So if that's the only file you've changed, there should be no difference. You said however that you also changed a few other files, so try restoring those to 3.0 (autopilot.nas and .xml).

Cheers,
Gijs
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400, DC-2, F-117, Jetman, L1011-500
FlightGear Liveries
User avatar
Gijs
Moderator
 
Posts: 8780
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 7

Re: FG 3.0 747-400 Autopilot

Postby sanhozay » Tue Mar 04, 2014 8:34 pm

I reset the branch before copying the old 747-400.xml in so the other files were current git. Only that file was changed.

The autothrottle seems to be broken in the current git and I'm wondering now if the autopilot instability is a result of that rather than the 747-400.xml file. I've just done another test with all files reset and controlling speed manually and the rest of the autopilot was a lot better, to the point where I was able to maintain an altitude and do an ILS approach and landing.

I'll do some more testing tomorrow; see if I can do an autopilot flight with manual throttle.
sanhozay
 
Posts: 238
Joined: Thu Dec 26, 2013 11:57 am
Location: EGNM
Callsign: G-SHOZ, EGGP_TW
Version: Git
OS: Xubuntu 13.10

Re: FG 3.0 747-400 Autopilot

Postby sanhozay » Wed Mar 05, 2014 11:09 am

OK, I must have been getting tired because I didn't reset all the files for that successful test. I was running with the "old" 747-400.xml.

To confirm:

a. The vertical modes of the autopilot are unstable with the "new" (2013205) 747-400.xml file. Replacing with the the "old" version (20130709) restores stability.

b. The autothrottle is broken in the sense that the SPD button on the glareshield panel does not work as it used to and the autopilot dialog doesn't set properties that the autopilot code expects.

Glareshield Panel:
When the SPD button is pressed, /autopilot/locks/speed is set to "speed-with-throttle-ias".
When the THR button is pressed, /autopilot/locks/speed is set to "speed-with-pitch-trim"

Autopilot Dialog:
When the "Speed with Throttle" radio button is selected, /autopilot/locks/speed is set to "speed-with-throttle".
When the "Speed with Pitch" radio button is selected, /autopilot/locks/speed is set to "speed-with-pitch-trim"

The "new" autopilot.xml file has changes at lines 1804 and 1836 that use "speed-with-throttle" to enable auto-throttle instead of "speed-with-throttle-ias". So the SPD button does not enable auto-throttle. On the other hand, all the servo drivers in that file work with "speed-with-throttle-ias" and the autopilot.nas file has lots of if statements that expect "speed-with-throttle-ias", so using the autopilot dialog to set "speed-with-throttle" doesn't work too well.

The simplest short-term solution is to revert those changes at lines 1804 and 1836 in autopilot.xml, changing "speed-with-throttle" back to "speed-with-throttle-ias". The SPD button can then be used to enable auto-throttle.

At least it seems to be flying again and those that want to can look at the new instruments.

ps. Is it just me, or has the texture disappeared from the forward part of the cockpit? I've just got glaring white. Overhead and pedestal are OK.
sanhozay
 
Posts: 238
Joined: Thu Dec 26, 2013 11:57 am
Location: EGNM
Callsign: G-SHOZ, EGGP_TW
Version: Git
OS: Xubuntu 13.10

Re: FG 3.0 747-400 Autopilot

Postby azims » Wed Mar 05, 2014 2:05 pm

Sanhozay,

I concur with all your comments regarding the autopilot. Yes, the forward cockpit texture has disappeared.

I have reverted back to the old 747 stable version as of now.
azims
 
Posts: 33
Joined: Mon Aug 12, 2013 7:56 pm
Callsign: AS
Version: 3.2
OS: Windows 7

Re: FG 3.0 747-400 Autopilot

Postby Gijs » Wed Mar 05, 2014 2:06 pm

Any error in the console about a missing texture?
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400, DC-2, F-117, Jetman, L1011-500
FlightGear Liveries
User avatar
Gijs
Moderator
 
Posts: 8780
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 7

Re: FG 3.0 747-400 Autopilot

Postby sanhozay » Wed Mar 05, 2014 2:26 pm

It seems to be missing forwardshadows2.png and forward-switches.png, plus a couple of apparently empty ones ...

Code: Select all
Enabling ATI viewport hack
Starting automatic scenery download/synchronization. Using built-in SVN support. Directory: '~/.fgfs/TerraSync'.
Cannot find image file ""
Cannot find image file ""
osgDB ac3d reader: could not find texture "forwardshadows2.png"

osgDB ac3d reader: could not find texture "forward-switches.png"

osgDB ac3d reader: could not find texture "forwardshadows2.png"

Failed to load file: "Aircraft/747-400/Models/Cockpit/Instruments/chronometer.xml"
Failed to load file: "Aircraft/747-400/Models/Cockpit/Instruments/chronometer.xml"
Could not find at least one of the following objects for animation: 'stab.trim.greenband'
environment init
747-400 electrical system by Ivan Ngeow.
747-400 hydraulic system: so far so good
Vspeeds are not calculated yet
Copilot ready
Pilot dual control ... initialized
Brake heating system... OK


These are the PNG files in the git clone:

Code: Select all
$ find . -name '*.png'
./Panels/744_elec_panel.png
./Panels/744_elec_sw.png
./Panels/744_hyd_panel.png
./Models/glass_shader.png
./Models/747-400_tire2.png
./Models/747-400_wingbottom.png
./Models/carpet.png
./Models/Liveries/KLM.png
./Models/747-400_engine.png
./Models/Effects/smoke.png
./Models/Effects/lightmap_cockpit.png
./Models/Effects/lightmap_overhead_switches.png
./Models/Effects/lightmap_glareshield.png
./Models/Effects/fire.png
./Models/Effects/lightmap_throttle.png
./Models/Effects/lightmap_pedestal.png
./Models/Effects/lightmap_forward.png
./Models/Effects/tiresmoke.png
./Models/Effects/lightmap_overhead.png
./Models/Effects/normalmap.png
./Models/Effects/particle.png
./Models/Effects/lightmap.png
./Models/Cockpit/glareshield_switches.png
./Models/Cockpit/digits.png
./Models/Cockpit/glareshield2.png
./Models/Cockpit/bottom.png
./Models/Cockpit/glass_shader.png
./Models/Cockpit/glareshield.png
./Models/Cockpit/alphabet.png
./Models/Cockpit/forward.png
./Models/Cockpit/Instruments/brake-pressure.png
./Models/Cockpit/Instruments/stby-asi.png
./Models/Cockpit/Instruments/mag-compass.png
./Models/Cockpit/Instruments/stby-ai.png
./Models/Cockpit/Instruments/stby-alt.png
./Models/Cockpit/Instruments/FMC/transparent.png
./Models/Cockpit/Instruments/EFB/transparent.png
./Models/Cockpit/yokes.png
./Models/Cockpit/seats.png
./Models/Cockpit/lettering.png
./Models/Cockpit/overhead_switches.png
./Models/Cockpit/screen-test.png
./Models/Cockpit/overhead_panel.png
./Models/Cockpit/transparent.png
./Models/Cockpit/throttle.png
./Models/Cockpit/cockpit.png
./Models/Cockpit/pedals.png
./Models/Cockpit/pedestal.png
./Models/747-400_fan.png
./Models/BOE.png
./Models/747-400_gear.png
./Models/747-400_misc.png
./Models/747-400_tire1.png
./Models/cockpit.png
./Models/747-400_wingtop.png
./Models/747-400_tire3.png
./splash.png
sanhozay
 
Posts: 238
Joined: Thu Dec 26, 2013 11:57 am
Location: EGNM
Callsign: G-SHOZ, EGGP_TW
Version: Git
OS: Xubuntu 13.10

Re: FG 3.0 747-400 Autopilot

Postby HelldiverSquadron » Thu Mar 06, 2014 4:37 pm

Ooohhh...forwardshadows2...
User avatar
HelldiverSquadron
 
Posts: 387
Joined: Sat Feb 16, 2013 6:35 pm
Callsign: Friend
Version: 3.0
OS: Windows 7 Ultimate

Re: FG 3.0 747-400 Autopilot

Postby Gijs » Thu Mar 06, 2014 7:07 pm

Argh, that's bad. You can probably replace all "forwardshadows2.png" with "forward.png" in Models/Cockpit/forward.ac to get the texture back.
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400, DC-2, F-117, Jetman, L1011-500
FlightGear Liveries
User avatar
Gijs
Moderator
 
Posts: 8780
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 7

Re: FG 3.0 747-400 Autopilot

Postby HelldiverSquadron » Tue Mar 11, 2014 2:59 am

tried it. doesnt seem to help. maybe its the .png itself?
User avatar
HelldiverSquadron
 
Posts: 387
Joined: Sat Feb 16, 2013 6:35 pm
Callsign: Friend
Version: 3.0
OS: Windows 7 Ultimate

Re: FG 3.0 747-400 Autopilot

Postby sanhozay » Tue Mar 11, 2014 7:38 am

That works for me. Note that there are two occurrences of forwardshadows2.png in that file.
sanhozay
 
Posts: 238
Joined: Thu Dec 26, 2013 11:57 am
Location: EGNM
Callsign: G-SHOZ, EGGP_TW
Version: Git
OS: Xubuntu 13.10

Re: FG 3.0 747-400 Autopilot

Postby azims » Wed Mar 12, 2014 4:38 pm

I made the changes as prescribed by sanhozay in autopilot.xml and replaced the 747-400.xml Also applied the changes by Gijs in forward.ac. Everything seems to be working well now.

BTW, the new version is very stable, very nice cockpit Gijs.
azims
 
Posts: 33
Joined: Mon Aug 12, 2013 7:56 pm
Callsign: AS
Version: 3.2
OS: Windows 7

Re: FG 3.0 747-400 Autopilot

Postby HelldiverSquadron » Wed Mar 12, 2014 10:13 pm

new version of the 747-400? itd be nice if the dual control was complete, so that the first officer could actually do what a copilot does its a cool flight deck for sure. glad the .png thing works
User avatar
HelldiverSquadron
 
Posts: 387
Joined: Sat Feb 16, 2013 6:35 pm
Callsign: Friend
Version: 3.0
OS: Windows 7 Ultimate

PreviousNext

Return to Aircraft

Who is online

Users browsing this forum: Google [Bot] and 9 guests