Board index FlightGear Support Installation Mac

FlightGear crash on mac

Installing FlightGear, scenery, aircraft etc. on Mac.

FlightGear crash on mac

Postby Uplink » Wed Jul 28, 2010 6:08 pm

Recently flightgear started hanging and then crashing on the splash screen when "Instilling Subsystems" appeared on my mac. This has happened before and I have solved the problem by running fg without all of the fluff. When this didn't work I re downloaded the latest version for macs. Version 2.0 I think. I still hung so I started to use the log. When I used the log level "info" I found this:
initializing FGMacOSXEventInput
Unknown exception in the main loop. Aborting...
Failed to untie property /instrumentation/turn-indicator[0]/serviceable
Failed to untie property /environment/density-inhg
Failed to untie property /environment/clouds/layer[0]/type
Failed to untie property /environment/clouds/layer[1]/type
Failed to untie property /environment/clouds/layer[2]/type
Failed to untie property /environment/clouds/layer[3]/type
Failed to untie property /environment/clouds/layer[4]/type
Failed to untie property /environment/weather-scenario
Failed to untie property /sim/temp/full-screen

Fg then went on and as far as I can tell deleted a bunch of temp vars:
Deleting char arrays
Deleting callback arrays
Deleting bindings
Deleting bindings for Adjust HUD Properties
Deleting bindings for Adjust LOD Ranges
Deleting bindings for Adjust View Position
Deleting bindings for Aircraft Help
Deleting bindings for Autopilot Settings
Deleting bindings for Basic Keys


This is only a very small part of the file, if you want the whole thing I can post it.

From what I can tell from the "about this mac" panel here are my computers specs:
My computer runs leopard
Processor: 2.4 GHz Intel Core 2 Duo
Memory: 2 GB 800 MHz DDR2 SDRAM

I also have a mighty mouse and bluetooth keyboard with no numberpad, I have tried runing fg without the mighty mouse with no success.
Uplink
 
Posts: 5
Joined: Tue Jun 29, 2010 4:27 pm

Re: FlightGear crash on mac

Postby gral » Wed Jul 28, 2010 10:42 pm

Uplink wrote:Recently flightgear started hanging and then crashing on the splash screen when "Instilling Subsystems" appeared on my mac. This has happened before and I have solved the problem by running fg without all of the fluff.


What is 'fluff' ?
Cheers- gral
gral
 
Posts: 325
Joined: Mon Nov 16, 2009 1:03 pm
Location: Zurich (Switzerland)
Callsign: HB-GRAL
Version: GIT

Re: FlightGear crash on mac

Postby Uplink » Thu Jul 29, 2010 1:05 am

Textures, AI models, Clouds, HUD, etc.
Uplink
 
Posts: 5
Joined: Tue Jun 29, 2010 4:27 pm

Re: FlightGear crash on mac

Postby gral » Thu Jul 29, 2010 9:12 am

Uplink wrote:Textures, AI models, Clouds, HUD, etc.


Do you start MacFG with default c172p at default airport KSFO ?
Can you post your whole log without any change in the log level ?
(When it is to large use http://www.pastebin.org and post only URL here).

Thanks- gral
gral
 
Posts: 325
Joined: Mon Nov 16, 2009 1:03 pm
Location: Zurich (Switzerland)
Callsign: HB-GRAL
Version: GIT

Re: FlightGear crash on mac

Postby Uplink » Thu Jul 29, 2010 3:53 pm

I use the Cessna 172P Skyhawk (1981 model) as my plane and start at KSFO.

Here is the full log: http://www.pastebin.org/428124
Uplink
 
Posts: 5
Joined: Tue Jun 29, 2010 4:27 pm

Re: FlightGear crash on mac

Postby gral » Thu Jul 29, 2010 10:27 pm

Uplink wrote:I also have a mighty mouse and bluetooth keyboard with no numberpad, I have tried runing fg without the mighty mouse with no success.


Can you try to start MacFG 2.0.0 without the bluetooth keyboard?
-gral
gral
 
Posts: 325
Joined: Mon Nov 16, 2009 1:03 pm
Location: Zurich (Switzerland)
Callsign: HB-GRAL
Version: GIT

Re: FlightGear crash on mac

Postby Uplink » Sun Aug 01, 2010 9:42 pm

I got my dads work computer keyboard, plugged it in, went thru the setup. then I went to System Prefs > Bluetooth and disconected both the bluetooth mouse and keyboard, then I swithed to FG (I launched it with the bluetooth keyboard and mouse attached) and launched the sim with the default plane at KSFO. It seemed to be working, but then it crashed. :(

The error log looked the same as the one I posted.
Uplink
 
Posts: 5
Joined: Tue Jun 29, 2010 4:27 pm

Re: FlightGear crash on mac

Postby gral » Tue Aug 03, 2010 10:36 pm

Uplink wrote:(I launched it with the bluetooth keyboard and mouse attached) and launched the sim with the default plane at KSFO. It seemed to be working, but then it crashed. :(


As I understand your reply you are launching MacFG still with bluetooth devices attached. So I hope this can help: Choose 'Go to folder' in the finder and type
Code: Select all
/Users/yourusername/.fgfs

Replace 'yourusername' with yours of course. Delete all content of this (hidden) folder and do *not* start FG again for the moment. First unplug all bluetooth devices and plug in an 'original' keyboard and mouse like you got one(?). Then restart your OSX and start FG again. Do you still get the same errors and logs?
Hope this helps. Maybe you should also try other aircrafts (like UFO) and other airports to start FG and doing this 'tests'.
-gral
BTW. Did you use a clean and fresh MacFlightGear install now without any add-ons like downloaded aircrafts etc.?
gral
 
Posts: 325
Joined: Mon Nov 16, 2009 1:03 pm
Location: Zurich (Switzerland)
Callsign: HB-GRAL
Version: GIT

Re: FlightGear crash on mac

Postby tat » Thu Aug 12, 2010 7:34 pm

The key point on the log is "unknown exception...." This closes fgfs.
The problem here is that this exception occurs on some Macs, but none of my Macs, so it is hard to debug.

A few weeks back, I borrowed my friend's Mac for catching the exception by adding the code below into bootstrap.cxx
....
} catch (const std::exception &e) {
cerr << "Fatal error: " << e.what() << endl;
}
...

And I got:
basic_string::_S_construct NULL not valid

This probably mean someone initialized C++ string with NULL pointer.
Bad thing is that it is hard to find where actually is the problem since it is caught by try - catch.
I tried setting a breakpoint on std::logic_error constructors , but no help.

Can someone find the cause of this exception (or find a better solution) for me?
Tat Nishioka
FlightGear Mac OS X Project
http://macflightgear.sourceforge.net
User avatar
tat
 
Posts: 176
Joined: Fri Dec 28, 2007 12:58 pm
Location: Yokohama, Japan
Callsign: tat

Re: FlightGear crash on mac

Postby tat » Sun Sep 05, 2010 5:18 pm

I think this one is fixed now...., but now that sure since I don't have a Mac that can reproduce this issue around me.
The updated fgfs is temporally available at:
http://macflightgear.sourceforge.net/wp ... 0/fgfs.zip
Please give it a try.

I believe that you can update fgfs by:
1) unzip fgfs.zip (Your browser might do it automatically)
2) open FlightGear.app
3) choose Advanced Features >> Others
4) press Install Add-On and choose fgfs.zip that you've downloaded
5) restart FlightGear.app

FYI, This fgfs will fix a crash that shows "unknown exception in the main loop" in the log.

Tat
Tat Nishioka
FlightGear Mac OS X Project
http://macflightgear.sourceforge.net
User avatar
tat
 
Posts: 176
Joined: Fri Dec 28, 2007 12:58 pm
Location: Yokohama, Japan
Callsign: tat

Re: FlightGear crash on mac

Postby Typist » Tue Sep 07, 2010 11:04 pm

This installation fails with error "invalid file or unknown destination".

PPC iMac, OSX 10.4.11 FlightGear 2.0.0
Typist
 
Posts: 9
Joined: Tue Sep 07, 2010 10:48 pm

Re: FlightGear crash on mac

Postby tat » Wed Sep 08, 2010 3:42 am

Oops, I should have made an easy install package.....
Anyway, you can try the following steps:

1) Open the data folder via Advanced Features >> Others >> Open Data Folder (then Finder opens the data folder)
2) Go up to Resources folder from Finder (Resource folder is a parent folder of data)
3) Copy fgfs to Resources folder (and replace the old fgfs with the new one

Good luck!

Tat
Tat Nishioka
FlightGear Mac OS X Project
http://macflightgear.sourceforge.net
User avatar
tat
 
Posts: 176
Joined: Fri Dec 28, 2007 12:58 pm
Location: Yokohama, Japan
Callsign: tat

Re: FlightGear crash on mac

Postby catsfive » Sat Mar 12, 2011 6:48 am

Hi, I am a new "user" but I'm not sure for how long. I can confirm that FG 2.0 will not start (Macbook i7 8GB RAM) with Bluetooth enabled. Is there some sort of fix available?
catsfive
 
Posts: 4
Joined: Sat Mar 12, 2011 6:26 am

Re: FlightGear crash on mac

Postby VicMar » Sat Mar 12, 2011 10:11 am

Hi catsfive,

We will need a bit more information about what happens. Just saying it doesn't work, when loads of other Mac users know it does isn't telling us what went wrong.

Start from the beginning and describe what you downloaded and exactly what you did with it. Then tell us exactly what happens, including any messages and/or reports you get.

Cheers,
Vic
Time flies like an arrow
Fruit flies like a banana

http://www.vicmar.weebly.com
User avatar
VicMar
 
Posts: 1616
Joined: Sun Apr 06, 2008 5:53 pm
Location: Lancing. UK (EGKA)
Callsign: VicMar
Version: 3.0.0
OS: OS X 10.8.5

Re: FlightGear crash on mac

Postby catsfive » Sat Mar 12, 2011 3:35 pm

Hi, Vic, OK, sure. Thank you. Here goes.

1) FlightGear 2.0 for OSX Mac (I'm running a Macbook i7 with 8GB RAM, NVidia GT 330M)

2) When I open it, I can pick any aircraft, any runway, it always tries to initialize but then lands me back at the main screen. I get two logs:

http://pastebin.com/QYzrVZt7

http://pastebin.com/d3nZ8inQ

I have downloaded several aircraft successfully. The aircraft appear to be properly installed in the DATA directory. I have tried it with numerous aircraft (all of which will preview wonderfully) but it won't go. When I open system preferences and turn off the Bluetooth capability the program will launch to the cockpit.

I don't have a joystick, I really just was looking for a program to fly around a little bit. So no worries if there's no fix I guess.
catsfive
 
Posts: 4
Joined: Sat Mar 12, 2011 6:26 am

Next

Return to Mac

Who is online

Users browsing this forum: No registered users and 1 guest