Board index FlightGear Support Installation Mac

Crashes while loading?

Installing FlightGear, scenery, aircraft etc. on Mac.

Crashes while loading?

Postby JayRavChan » Sun Feb 19, 2012 8:44 pm

Hey, FlightGear keeps crashing (On my Mac 10.6.8) whenever I click the "Start Flight" button. I am reinstalling the program, so hopefully it works this time. Any other suggestions? I also moved it to my applications folder like it asked me to.
JayRavChan
 
Posts: 3
Joined: Sun Feb 19, 2012 8:31 pm

Bug when loading Flight Gear

Postby JayRavChan » Sun Feb 19, 2012 11:28 pm

After I copied FlightGear to my Macbook Pro (10.6.8) applications folder, I opened the game, and clicked "Start Flight". Things seemed to be going well. The map appeared, but then it crashed very shortly after that. I wasn't able to even see the plane.

Here is what Terminal grabbed for me. The problem occurs near the end I assume?:


b-ravichanders-macbook-pro-5:~ jon$ /Applications/FlightGear.app/Contents/MacOS/FlightGear ; exit;
2012-02-19 17:18:18.097 FlightGear[18555:903] *** __NSAutoreleaseNoPool(): Object 0x208ad0 of class NSThread autoreleased with no pool in place - just leaking
Starting Atlas with --fg-root=./data --fg-scenery=./data/Scenery-TerraSync --palette=./data/Atlas/Palettes/default.ap --udp=5050 --atlas=./data/Atlas --autocenter-mode
shell: current dir: /Applications/FlightGear.app/Contents/Resources
/Applications/FlightGear.app/Contents/Resources/FlightGearController.rb:47:in `initialize': Ruby threads cannot be used in RubyCocoa without patches to the Ruby interpreter
Starting fgfs.sh with --control=keyboard --enable-terrasync --prop:/sim/terrasync/refresh-display=true --airport=CYYZ --nmea=socket,out,1,localhost,5050,udp --aircraft=b1900d --browser-app=open --disable-real-weather-fetch --disable-clouds3d
shell: current dir: /Applications/FlightGear.app/Contents/Resources
/Applications/FlightGear.app/Contents/Resources/FlightGearController.rb:47:in `initialize': Ruby threads cannot be used in RubyCocoa without patches to the Ruby interpreter
Airplane image file /Applications/FlightGear.app/Contents/Resources/data/Atlas/airplane_image.png was not found.
Falling back to line drawing
Exiting fgfs.sh
Exiting Atlas
logout

[Process completed]

I really want to play this game. Please help me. Other people I have talked to on Facebook have similar issues. It says something about "Ruby thread"? Might be the problem. Just throwing things out there. "Initializing subsystems" is the last thing I see when it crashes.
JayRavChan
 
Posts: 3
Joined: Sun Feb 19, 2012 8:31 pm

Re: Crashes while loading?

Postby JayRavChan » Sun Feb 19, 2012 11:42 pm

This was an update that was on the website. But I don't know what to do. I have the latest version of FlightGear. Was I supposed to download a previous Mac version before the 2.6?

http://macflightgear.sourceforge.net/home/development-notes/

Look under the heading "Dangerous code, indeed"
JayRavChan
 
Posts: 3
Joined: Sun Feb 19, 2012 8:31 pm

Re: Crashes while loading?

Postby tat » Mon Feb 20, 2012 7:53 pm

Thanks for the report.

Ruby Thread thing is innocent. Though It's annoying, it doesn't hurt FG. :-)
Plus, the link you mentioned on the third post is for very old version (3-4 years back) and has nothing to do with this issue.

The problem here is a known issue (case #1 in viewtopic.php?f=21&t=15395).
If you can fly c172p, A6M2-jsbsim, but crashe with CitationX, 777-200ER, or b1900d, this is the case.

This problem is already fixed on my end and the official updater (or a full package) will be soon available.
Meanwhile you can use the experimental updater. See below for the instruction:
http://macflightgear.sourceforge.net/fg ... -quick-fix

Tat
Tat Nishioka
FlightGear Mac OS X Project
http://macflightgear.sourceforge.net
User avatar
tat
 
Posts: 176
Joined: Fri Dec 28, 2007 12:58 pm
Location: Yokohama, Japan
Callsign: tat

Re: Crashes while loading?

Postby golferguy64 » Mon Aug 06, 2012 10:50 am

New to FG, and loving it, but having the above issue with no resolution after the fix. OS X 10.7.4, using FG 2.6.0. I applied the GUI fix, and still doesn't load up. I used to be able to run in 64 bit mode, but now it won't open up with it. This is only after I ran the fix...thoughts? In non-64 bit mode, I can fly the C72, but not any of the others. (and the map connection to the iPad is awesome!!)

Here is what my console reads:

8/6/12 8:37:54.930 PM [0x0-0x4f04f].net.sourceforge.macflightgear: /Applications/FlightGear.app/Contents/Resources/FlightGearController.rb:47:in `initialize': Ruby threads cannot be used in RubyCocoa without patches to the Ruby interpreter
8/6/12 8:37:54.930 PM [0x0-0x4f04f].net.sourceforge.macflightgear: Exiting fgfs.sh
8/6/12 8:37:54.930 PM [0x0-0x4f04f].net.sourceforge.macflightgear: Starting fgfs.sh with --enable-terrasync --prop:/sim/terrasync/refresh-display=true --aircraft=c172p-2dpanel --browser-app=open --airport=KSEA --disable-save-on-exit --timeofday=noon --control=keyboard --enable-hud-3d --disable-real-weather-fetch fgfs --generic=socket,out,5,10.1.1.4,9999,udp,mobatlas --enable-fullscreen --prop:/sim/rendering/multi-sample-buffers=true --prop:/sim/rendering/multi-samples=3 --geometry=2560x1600
8/6/12 8:37:54.930 PM [0x0-0x4f04f].net.sourceforge.macflightgear: shell: current dir: /Applications/FlightGear.app/Contents/Resources
golferguy64
 
Posts: 2
Joined: Mon Aug 06, 2012 10:39 am


Return to Mac

Who is online

Users browsing this forum: No registered users and 2 guests

cron