Board index FlightGear Support Installation Mac

Disabling Material Shaders  Topic is solved

Installing FlightGear, scenery, aircraft etc. on Mac.

Disabling Material Shaders

Postby VicMar » Sun Aug 28, 2011 3:13 pm

Hi,

When I start V2.4.0 my fps is dreadful unless I uncheck the Material Shaders.

Is there a command line I can add which will let me start up with material shaders disabled?

Alternatively, is there an alteration I can make somewhere in the source code which will give the same result.

Any help appreciated.

Vic
p.s. I know the real problem is my lack of RAM, but other priorities are using my funds at present.
Last edited by VicMar on Mon Aug 29, 2011 7:49 am, edited 1 time in total.
Time flies like an arrow
Fruit flies like a banana

http://www.vicmar.weebly.com
User avatar
VicMar
 
Posts: 1616
Joined: Sun Apr 06, 2008 5:53 pm
Location: Lancing. UK (EGKA)
Callsign: VicMar
Version: 3.0.0
OS: OS X 10.8.5

Re: Disabling Materiall Shaders

Postby Sealbhach » Sun Aug 28, 2011 9:27 pm

You can edit the file data/materials.xml and comment out the effects lines. So open up that file and for example to comment out the forest effect you would add a !-- and a -- to the beginning and end of that line. See example below:

Code: Select all
 <material>
  <condition>
   <equals>
    <property>sim/startup/season</property>
    <value>summer</value>
   </equals>
  </condition>
  <!--effect>Effects/forest</effect-->
  <name>MixedForestCover</name>
  <name>MixedForest</name>
  <name>RainForest</name>


You can experiment a little by disabling other effects. Just use the search function of your text editor to search for the word "effect". Note that there are two sets of materials textures, one for summer and one for winter.

.
Sealbhach
 
Posts: 942
Joined: Wed Jun 30, 2010 9:17 am

Re: Disabling Materiall Shaders

Postby emarkay » Sun Aug 28, 2011 9:30 pm

RAM, VRAM, cache, Megahertz or Gigahertz? You admit a limitation - be specific; what is it; how do you "know" your issue is RAM?
Give more details on your OS, hardware, specifics and of course, FG version, and then maybe we can assist.
Therefore, are you sure it's the Material Shading that is the issue?
emarkay
 
Posts: 79
Joined: Sun Jan 07, 2007 10:39 pm
Location: Southern Indiana
Version: 2.10
OS: Ubuntu 12.04 LTS

Re: Disabling Materiall Shaders

Postby Thorsten » Mon Aug 29, 2011 6:35 am

Therefore, are you sure it's the Material Shading that is the issue?


I'd safely assume that if any problems go away if material shaders are disabled, then the issue is material shaders...

In /gui/dialogs/rendering.xml, the property switched by the menu is

Code: Select all
/sim/rendering/shader-effects


First thing I'd try is to set this to false in the commandline. Second thing I'd try is to add this to preferences.xml. If nothing else helps, a Nasal setprop() at runtime should do the trick.
Thorsten
 
Posts: 3132
Joined: Mon Nov 02, 2009 8:33 am

Re: Disabling Materiall Shaders

Postby VicMar » Mon Aug 29, 2011 7:44 am

@ Saalbhach & Thorsten,

Thank you both for your excellent replies. I will follow the paths you have given me to try.

@ emarkay
how do you "know" your issue is RAM?
I know this because of other issues which have pointed to a lack of RAM. I currently only have 1GB, when my iMac can take up to 4GB.
are you sure it's the Material Shading that is the issue?
As Thorsten pointed out - With Material Shaders checked, I get a very dull screen, which shows most textures as the default colour unless light is directly shining on them. I also have fps of 5 - 15.

With Material Shaders un-checked my screen is bright, all textures show brightly, and my fps jumps to 55 - 60.

Nuff said?

Give more details on your OS, hardware, specifics and of course, FG version, and then maybe we can assist.
If you bothered to read my first message you will have seen which version I am asking about. If you bothered to look at the information which is on the right hand side of my message, you will see that I am a Mac user. That also shows which version of OS X I run, and that I am 'Blessed' with an ATI Graphics card. I also know my graphics card is inbuilt to my mother board and therefore can't be updated or replaced.

You might also note that I have been on the forum for a little while. I offer help where I can, usually about modelling scenery. In fact I started using FG when it was at the Version 0.9.8 stage. I usually manage to keep my messages light, if not amusing. I have been known to blow my top at someone who has annoyed me over a great period until it becomes unbearable, but I never treat people as idiots until they have proved they are one. I don't appreciate getting messages like yours. If I thought that sort of information was required to answer my question, I would have provided it.

Unless you (emarkay) can agree to get out of the correct side of the bed on the day you write, please don't bother to answer any more of my messages. I find your manner offensive and rude.


Thanks again to Saalbhach & Thorsten.

Best regards,
Vic
Time flies like an arrow
Fruit flies like a banana

http://www.vicmar.weebly.com
User avatar
VicMar
 
Posts: 1616
Joined: Sun Apr 06, 2008 5:53 pm
Location: Lancing. UK (EGKA)
Callsign: VicMar
Version: 3.0.0
OS: OS X 10.8.5

Re: Disabling Material Shaders

Postby VicMar » Mon Aug 29, 2011 4:37 pm

Hi again,
I have tried to follow Thorsten’s methods, but admit I am not much good with command line input.

I searched through the options page but couldn’t find a suitable entry for this purpose, so I tried the following, one at a time (of course):

/sim/rendering/shader-effects=false
/sim/rendering/shader-effects="false"
--disable-/sim/rendering/shader-effects
--disable-sim-rendering-shader-effects
--sim-rendering-shader-effects=false
--sim-rendering-shader-effects="false"

With any of the above in the command line fgfs didn’t start at all.

If there is a proper format for disabling the material shaders in the command line, I would appreciate any suggestions.

I then tried Saalbhach’s remedy and commented out every ‘effect’ in the materials.xml file.

This time fgfs started OK, but I still had the dull screen until I unchecked the ‘Material Shaders’ box.
Image
Image

The fact that the Material Shaders box appears as checked on startup makes me think I am not attacking the correct target.

Any more suggestions please.

Cheers,
Vic
Time flies like an arrow
Fruit flies like a banana

http://www.vicmar.weebly.com
User avatar
VicMar
 
Posts: 1616
Joined: Sun Apr 06, 2008 5:53 pm
Location: Lancing. UK (EGKA)
Callsign: VicMar
Version: 3.0.0
OS: OS X 10.8.5

Re: Disabling Material Shaders  

Postby Gijs » Mon Aug 29, 2011 6:42 pm

You want --prop:/sim/rendering/shader-effects=false or something similar ;)
--prop: tells FlightGear this command sets a property.
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400, DC-2, F-117, Jetman, L1011-500
FlightGear Liveries
User avatar
Gijs
Moderator
 
Posts: 8715
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 7

Re: Disabling Material Shaders

Postby VicMar » Mon Aug 29, 2011 7:43 pm

Gijs said
"You want --prop:/sim/rendering/shader-effects=false"
Yay Gijs.
You got it first go!!!

This command line still allows me to turn the material shaders on if I want to.

Thanks everyone who contributed to find the solution.

Cheers,
Vic
Time flies like an arrow
Fruit flies like a banana

http://www.vicmar.weebly.com
User avatar
VicMar
 
Posts: 1616
Joined: Sun Apr 06, 2008 5:53 pm
Location: Lancing. UK (EGKA)
Callsign: VicMar
Version: 3.0.0
OS: OS X 10.8.5

Re: Disabling Material Shaders

Postby Dragonmaster Lou » Tue Aug 30, 2011 2:20 pm

Out of curiosity, what are your antialiasing settings? On my 2009-era iMac, I found that the framerate is horrible with antialiasing above 4 or so and material shaders on, but if I turn AA down it works much better.
Dragonmaster Lou
 
Posts: 29
Joined: Fri Jul 15, 2011 2:58 pm

Re: Disabling Material Shaders

Postby VicMar » Tue Aug 30, 2011 4:26 pm

Dragonmaster Lou said;
if I turn AA down it works much better.
Hi Dragonmaster Lou, I am obviously not as technical as you. I was unaware that there was any adjustment possible there, nor that it could affect fps rates.

If you can tell me how to check it, I'll tell you what my anti-aliasing is set at.

If it is easy to change, I'll try to adjust it to it's optimum.

Cheers,
Vic
Time flies like an arrow
Fruit flies like a banana

http://www.vicmar.weebly.com
User avatar
VicMar
 
Posts: 1616
Joined: Sun Apr 06, 2008 5:53 pm
Location: Lancing. UK (EGKA)
Callsign: VicMar
Version: 3.0.0
OS: OS X 10.8.5

Re: Disabling Material Shaders

Postby Dragonmaster Lou » Tue Aug 30, 2011 8:53 pm

I'm assuming you're using the official Mac FlightGear version (AKA FlightGear.app). I'm not in front of my FlightGear computer right now (no electricity at home due to Hurricane Irene), so I'm working a bit on memory here. However, if you click on the "Advanced Options" triangle near the bottom of the window and then go to the "Rendering" tab, you should see an Anti-Aliasing slider there. Play with its settings a bit to see what works best and looks best for your particular setup.
Last edited by Gijs on Tue Aug 30, 2011 9:23 pm, edited 1 time in total.
Reason: No useless quoting please.
Dragonmaster Lou
 
Posts: 29
Joined: Fri Jul 15, 2011 2:58 pm

Re: Disabling Material Shaders

Postby VicMar » Tue Aug 30, 2011 9:28 pm

Sorry to hear Irene has been getting at you. I hope there is nothing too terrible and/or permanent in your household.

On the Mac launcher, I only get anti-alias ON or OFF. So no room to tinker there. I will however see if the on/off makes any noticeable difference.

Thanks for the prompt.
Best,
Vic
Time flies like an arrow
Fruit flies like a banana

http://www.vicmar.weebly.com
User avatar
VicMar
 
Posts: 1616
Joined: Sun Apr 06, 2008 5:53 pm
Location: Lancing. UK (EGKA)
Callsign: VicMar
Version: 3.0.0
OS: OS X 10.8.5

Re: Disabling Material Shaders

Postby Dragonmaster Lou » Wed Aug 31, 2011 2:27 pm

No problem. Once I get power, I'll take a look at the settings and maybe even post some screenshots to help out.

Fortunately, Irene didn't do any permanent damage except for a single tree that luckily isn't near anything that it could've damaged as well. About the only issue I'm having is the nuisance of not having power, but it could be worse. I can't help but feel sorry for the people up in Vermont, for instance.
Dragonmaster Lou
 
Posts: 29
Joined: Fri Jul 15, 2011 2:58 pm

Re: Disabling Material Shaders

Postby VicMar » Wed Aug 31, 2011 2:47 pm

The only time I have experienced a hurricane was back in 1987 when one visited the south coast of the UK. We had millions of trees blown down and the resulting damage and supplies interruptions took a while to get sorted. Our train services were disrupted for several days, which meant I couldn't get to my office, and had to go to a local one, where they were suspicious and wouldn't give me anything to do. So I stayed home till the trains were running again properly.

Fortunately this was a one off. Hurricanes usually don't come anywhere near us over here. We get a few tornados, but they are nothing compared to the ones the USA gets. In fact I saw a dust devil in a local car park this morning. Only a few yards wide, but it was moving a fair bit of dirt about. Perhaps there is a good side to the UK's climate after all. :)

Cheers,
Vic
Time flies like an arrow
Fruit flies like a banana

http://www.vicmar.weebly.com
User avatar
VicMar
 
Posts: 1616
Joined: Sun Apr 06, 2008 5:53 pm
Location: Lancing. UK (EGKA)
Callsign: VicMar
Version: 3.0.0
OS: OS X 10.8.5

Re: Disabling Material Shaders

Postby Dragonmaster Lou » Wed Aug 31, 2011 4:18 pm

I'm in New England, so hurricanes here aren't all that common either, though apparently more common than the UK from the looks of it. This is my third hurricane (okay, technically Irene was a tropical storm by the time it arrived here, but it was still pretty close to hurricane strength), having lived in New England my entire life. This is the first one that's hit us in about 20 years though -- the last being Bob in 91 or so. Prior to that there was Gloria in 86. Fortunately, I didn't suffer from much other than being without power during all 3 storms.
Dragonmaster Lou
 
Posts: 29
Joined: Fri Jul 15, 2011 2:58 pm

Next

Return to Mac

Who is online

Users browsing this forum: No registered users and 2 guests